404 Error after login when pushing image to company.artifactory.com

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

404 Error after login when pushing image to company.artifactory.com

janjuna
Hello,

we have an account on artifactory where we store our docker images but on our server when we try to push new image we are getting this error:

docker push company.artifactoryonline.com/app-name
The push refers to a repository [company.artifactoryonline.com/app-name] (len: 2)
Sending image list

Please login prior to push:
Username: janjuna
Password:
Email: my@mail.com
Error response from daemon: Login: {
  "errors" : [ {
    "status" : 404,
    "message" : "Not Found"
  } ]
} (Code: 404; Headers: map[Server:[Artifactory/4.7.1] X-Artifactory-Id:[aolprod2b-paradata] X-Node:[nginx3c.prod-usw1] Connection:[keep-alive] Content-Type:[application/json] Date:[Mon, 04 Apr 2016 13:25:46 GMT]])


docker -v says:
Docker version 1.9.1, build a34a1d5/1.9.1

Can you help me please what is wrong there? I am completely out of ideas ..
Reply | Threaded
Open this post in threaded view
|

Re: 404 Error after login when pushing image to company.artifactory.com

janjuna
Just one line :-(
set NO_PROXY=/var/run/docker.sock
Reply | Threaded
Open this post in threaded view
|

Re: 404 Error after login when pushing image to company.artifactory.com

todd
@janjuna

I am getting the same error, but I don't understand how to fix it (using your solution).

Where do I add "set NO_PROXY=/var/run/docker.sock" ?

Thanks for your help.