Carbonfive site not downloading

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Carbonfive site not downloading

Karl Neilsen
I have had the mvn site for Carbonfive (a db-migration plugin) working and for some reason last week it quit working. I am not really seeing any error messages in the access.log file. Where should I look next?

See attached image for configuration settings. Here is the full url that it is trying to hit: http://mvn.carbonfive.com/nexus/content/groups/public/ (the image cut it off)

TIA

Karl~

------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users

carbonfive.tiff (179K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Carbonfive site not downloading

Yoav Landman
Administrator
The artifactory.log should contain warnings/errors whenever remote artifact fetching doesn't succeed.
What is the URL of the jar you are trying to download? We also have the Carbonfive repo proxied from http://repo.jfrog.org, so you can try it from there and see if it's reproducible.

Thanks,

Yoav
On Tue, Jul 28, 2009 at 12:30 AM, Karl Nielsen <[hidden email]> wrote:
I have had the mvn site for Carbonfive (a db-migration plugin) working and for some reason last week it quit working. I am not really seeing any error messages in the access.log file. Where should I look next?

See attached image for configuration settings. Here is the full url that it is trying to hit: http://mvn.carbonfive.com/nexus/content/groups/public/ (the image cut it off)

TIA

Karl~

------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Carbonfive site not downloading

Karl Neilsen
This is what I have in the System Logs:

2009-07-27 17:11:23,243 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom'...
2009-07-27 17:11:23,400 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom.sha1'...
2009-07-27 17:11:23,525 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom.md5'...

But my build fails with this message:

Project ID: com.carbonfive:db-support-parent:pom:0.9.7

Reason: Cannot find parent: com.carbonfive:c5-parent for project: com.carbonfive:db-support-parent:pom:0.9.7 for project com.carbonfive:db-support-parent:pom:0.9.7

I am wondering if something got messed up in my pom? I even tried pointing it to the jfrog server and got the same error message:

    <repositories>

        <repository>

            <id>central</id>

            <url>http://repo.jfrog.org:80/artifactory/repo/</url>

            <snapshots>

                <enabled>false</enabled>

            </snapshots>

        </repository>

    </repositories>


I am sure that it is something simple, but I have looked for it all day and nothing...


On Mon, Jul 27, 2009 at 5:34 PM, Yoav Landman <[hidden email]> wrote:
The artifactory.log should contain warnings/errors whenever remote artifact fetching doesn't succeed.
What is the URL of the jar you are trying to download? We also have the Carbonfive repo proxied from http://repo.jfrog.org, so you can try it from there and see if it's reproducible.

Thanks,

Yoav
On Tue, Jul 28, 2009 at 12:30 AM, Karl Nielsen <[hidden email]> wrote:
I have had the mvn site for Carbonfive (a db-migration plugin) working and for some reason last week it quit working. I am not really seeing any error messages in the access.log file. Where should I look next?

See attached image for configuration settings. Here is the full url that it is trying to hit: http://mvn.carbonfive.com/nexus/content/groups/public/ (the image cut it off)

TIA

Karl~

------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Carbonfive site not downloading

Frederic Simon
Looks like the parent pom c5-parent is the issue.
It is here: http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/c5-parent/6/c5-parent-6.pom
So if it's not in your remote repository cache some logs should show the issue.
If it is, check that the pom is valid, or just delete the cache to refresh it.

HTH,
Fred

On Tue, Jul 28, 2009 at 6:27 AM, Karl Nielsen <[hidden email]> wrote:
This is what I have in the System Logs:

2009-07-27 17:11:23,243 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom'...
2009-07-27 17:11:23,400 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom.sha1'...
2009-07-27 17:11:23,525 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom.md5'...

But my build fails with this message:

Project ID: com.carbonfive:db-support-parent:pom:0.9.7

Reason: Cannot find parent: com.carbonfive:c5-parent for project: com.carbonfive:db-support-parent:pom:0.9.7 for project com.carbonfive:db-support-parent:pom:0.9.7

I am wondering if something got messed up in my pom? I even tried pointing it to the jfrog server and got the same error message:

    <repositories>

        <repository>

            <id>central</id>

            <url>http://repo.jfrog.org:80/artifactory/repo/</url>

            <snapshots>

                <enabled>false</enabled>

            </snapshots>

        </repository>

    </repositories>


I am sure that it is something simple, but I have looked for it all day and nothing...


On Mon, Jul 27, 2009 at 5:34 PM, Yoav Landman <[hidden email]> wrote:
The artifactory.log should contain warnings/errors whenever remote artifact fetching doesn't succeed.
What is the URL of the jar you are trying to download? We also have the Carbonfive repo proxied from http://repo.jfrog.org, so you can try it from there and see if it's reproducible.

Thanks,

Yoav
On Tue, Jul 28, 2009 at 12:30 AM, Karl Nielsen <[hidden email]> wrote:
I have had the mvn site for Carbonfive (a db-migration plugin) working and for some reason last week it quit working. I am not really seeing any error messages in the access.log file. Where should I look next?

See attached image for configuration settings. Here is the full url that it is trying to hit: http://mvn.carbonfive.com/nexus/content/groups/public/ (the image cut it off)

TIA

Karl~

------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users




--
JFrog Ltd
5 Habonim st., P.O.Box 8187
Netanya, Israel 42504.
Tel: +972 9 8941444    
Fax: +972 9 8659977
http://www.jfrog.org/
http://freddy33.blogspot.com/
http://nothingisinfinite.blogspot.com/

------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Carbonfive site not downloading

Yoav Landman
Administrator
In reply to this post by Karl Neilsen
Have you tried moving away com/carnobfive from you local m2 repository and zapping the c5-public-repo cahces in Artifactory?

On Tue, Jul 28, 2009 at 6:27 AM, Karl Nielsen <[hidden email]> wrote:
This is what I have in the System Logs:

2009-07-27 17:11:23,243 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom'...
2009-07-27 17:11:23,400 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom.sha1'...
2009-07-27 17:11:23,525 [INFO ] (o.a.r.HttpRepo :152) - c5-public-repository: Retrieving 'http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-support-parent/0.9.7/db-support-parent-0.9.7.pom.md5'...

But my build fails with this message:

Project ID: com.carbonfive:db-support-parent:pom:0.9.7

Reason: Cannot find parent: com.carbonfive:c5-parent for project: com.carbonfive:db-support-parent:pom:0.9.7 for project com.carbonfive:db-support-parent:pom:0.9.7

I am wondering if something got messed up in my pom? I even tried pointing it to the jfrog server and got the same error message:

    <repositories>

        <repository>

            <id>central</id>

            <url>http://repo.jfrog.org:80/artifactory/repo/</url>

            <snapshots>

                <enabled>false</enabled>

            </snapshots>

        </repository>

    </repositories>


I am sure that it is something simple, but I have looked for it all day and nothing...


On Mon, Jul 27, 2009 at 5:34 PM, Yoav Landman <[hidden email]> wrote:
The artifactory.log should contain warnings/errors whenever remote artifact fetching doesn't succeed.
What is the URL of the jar you are trying to download? We also have the Carbonfive repo proxied from http://repo.jfrog.org, so you can try it from there and see if it's reproducible.

Thanks,

Yoav
On Tue, Jul 28, 2009 at 12:30 AM, Karl Nielsen <[hidden email]> wrote:
I have had the mvn site for Carbonfive (a db-migration plugin) working and for some reason last week it quit working. I am not really seeing any error messages in the access.log file. Where should I look next?

See attached image for configuration settings. Here is the full url that it is trying to hit: http://mvn.carbonfive.com/nexus/content/groups/public/ (the image cut it off)

TIA

Karl~

------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Carbonfive site not downloading

starver

Replying to document the fix: Note the double slash in ../public//com/...
Remove the trailing slash in the config url will remove the double slash in
your effective url and should fix the problem.


Yoav  Landman wrote:

>
> Have you tried moving away com/carnobfive from you local m2 repository and
> zapping the c5-public-repo cahces in Artifactory?
>
> On Tue, Jul 28, 2009 at 6:27 AM, Karl Nielsen
> <[hidden email]>wrote:
>
>> This is what I have in the System Logs:
>> 2009-07-27 17:11:22,525 [INFO ] (o.a.r.HttpRepo :152) -
>> c5-public-repository: Retrieving '
>> http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-migration-maven-plugin/0.9.7/db-migration-maven-plugin-0.9.7.pom.sha1'.<http://mvn.carbonfive.com/nexus/content/groups/public//com/carbonfive/db-migration-maven-plugin/0.9.7/db-migration-maven-plugin-0.9.7.pom.sha1%27.>
>> ..
> ...
>>
>> But my build fails with this message:
>>
>> Project ID: com.carbonfive:db-support-parent:pom:0.9.7
>>
>> Reason: Cannot find parent: com.carbonfive:c5-parent for project:
>> com.carbonfive:db-support-parent:pom:0.9.7 for project
>> com.carbonfive:db-support-parent:pom:0.9.7
>>
>> I am wondering if something got messed up in my pom? I even tried
>> pointing
>> it to the jfrog server and got the same error message:
>>
>>     <repositories>
>>         <repository>
>>             <id>central</id>
>>             <url>http://repo.jfrog.org:80/artifactory/repo/</url>
>>             <snapshots>
>>                 <enabled>false</enabled>
>>             </snapshots>
>>         </repository>
>>     </repositories>
>>
>>
>> I am sure that it is something simple, but I have looked for it all day
>> and
>> nothing...
>>
> ...
>

--
View this message in context: http://old.nabble.com/Carbonfive-site-not-downloading-tp24689029p26581618.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Join us December 9, 2009 for the Red Hat Virtual Experience,
a free event focused on virtualization and cloud computing.
Attend in-depth sessions from your desk. Your couch. Anywhere.
http://p.sf.net/sfu/redhat-sfdev2dev
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users