Couldn't "DeleteVersions..." in artifactory

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Couldn't "DeleteVersions..." in artifactory

WarrenChen
Hi all,

Need the urgent help here:

The Team managed to publish the project related artifacts to the Artifactory via:
Ant-ivy script. And the structure as following:

Type1:


Type2:


The ivysetting.xml config:
        <property name="ivy.shared.default.root"             value="http://[ServerName]:8081/artifactory" override="true"/>       
        <property name="ivy.shared.default.ivy.pattern"      value="[organization]/[module]/[revision]/[type]s/ivy-[revision].xml" override="true"/>
        <property name="ivy.shared.default.artifact.pattern" value="[organization]/[module]/[revision]/[type]s/[module](-[classifier])-[revision].[ext]" override="true"/>


For both type1 and type2 publishes, I just couldn't "delete versions" [always shows no record found] in Artifactory:
For Type2:

For Type1:



Central_Configuration_Descriptor.txt

Anyone knows what cause the problem and how to correct it? Many thanks for the help!!

Warren Chen
Reply | Threaded
Open this post in threaded view
|

Re: Couldn't "DeleteVersions..." in artifactory

WarrenChen
Also attached the central configuration file xml.
Reply | Threaded
Open this post in threaded view
|

Re: Couldn't "DeleteVersions..." in artifactory

dave_p
In reply to this post by WarrenChen
Does the user account they are using have delete permissions for the repository they are pushing to?

On Aug 17, 2014, at 7:40 PM, WarrenChen <[hidden email]> wrote:

> Hi all,
>
> Need the urgent help here:
>
> The Team managed to publish the project related artifacts to the Artifactory
> via:
> Ant-ivy script. And the structure as following:
>
> Type1:
> <http://forums.jfrog.org/file/n7579949/type1.jpg>
>
> Type2:
> <http://forums.jfrog.org/file/n7579949/Type2.jpg>
>
> The ivysetting.xml config:
> <property name="ivy.shared.default.root"            
> value="http://[ServerName]:8081/artifactory" override="true"/>
> <property name="ivy.shared.default.ivy.pattern"    
> value="[organization]/[module]/[revision]/[type]s/ivy-[revision].xml"
> override="true"/>
> <property name="ivy.shared.default.artifact.pattern"
> value="[organization]/[module]/[revision]/[type]s/[module](-[classifier])-[revision].[ext]"
> override="true"/>
>
>
> For both type1 and type2 publishes, I just couldn't "delete versions"
> [always shows no record found] in Artifactory:
> For Type2:
> <http://forums.jfrog.org/file/n7579949/cannot_delete_versions_type2.png>
> For Type1:
> <http://forums.jfrog.org/file/n7579949/cannot_delete_versions_type1.png>
>
>
> Central_Configuration_Descriptor.txt
> <http://forums.jfrog.org/file/n7579949/Central_Configuration_Descriptor.txt>  
>
> Anyone knows what cause the problem and how to correct it? Many thanks for
> the help!!
>
> Warren Chen
>
>
>
>
> --
> View this message in context: http://forums.jfrog.org/Couldn-t-DeleteVersions-in-artifactory-tp7579949.html
> Sent from the Artifactory - Users mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Couldn't "DeleteVersions..." in artifactory

WarrenChen
Hi Dave,

I am using the admin user who has all the permissions.