Edit repository doesn't save advanced settings (username / password)‏

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Edit repository doesn't save advanced settings (username / password)‏

Frédéric THOMAS
Hi,

I use Artifactory 3.0.4 and proxies a repo where I can't remember having set a network username and password to access it, I manage as well this remote repo, anyway, when I try to remove this username and password from the advanced settings and save, artifactory doesn't save it, when I come back on the advanced settings, the username and password are still there, other fields are saved correctly, what am I missing ?

That's very problematic as the remote repo is set to accept anonymous requests but having it been requested with a username and password avoid me to download any artifacts from. [1]

I tried as well to delete and re-create the remote repo without luck, the deletion doesn't work.

Thanks,
Frédéric THOMAS

[1]
2014-01-20 23:10:07,811 [http-bio-8085-exec-2015] [INFO ] (o.a.c.h.a.AuthChallengeProcessor:101) - basic authentication scheme selected
2014-01-20 23:10:07,811 [http-bio-8085-exec-2015] [INFO ] (o.a.c.h.HttpMethodDirector:722) - Failure authenticating with BASIC 'Artifactory Realm'@apacheflexvm.cloudapp.net:80
2014-01-20 23:17:18,753 [http-bio-8085-exec-1958] [INFO ] (o.a.w.w.a.ArtifactoryRequestCycleListener:57) - User anonymous accessed unauthorized resource. Not authorized to instantiate class org.artifactory.webapp.wicket.page.logs.SystemLogsPage
Reply | Threaded
Open this post in threaded view
|

Re: Edit repository doesn't save advanced settings (username / password)‏

Frédéric THOMAS
Hi,

I update myself has I hadn't got any answer yet.

The fact the artefact wasn't downloaded was because it was corrupt in the remote repo and I checked "Reject Invalid Jar Archives".

Anyway, remains the fact that connected on the local machine as Admin on Artifactory, I can delete a remote repo, not true thru HTTP, also, the fields relative to the remote credentials (username and password) are filled when look at my remote repo from Http access and not from localhost and I don't know if it is an expected behaviour or not, it seems it should be the same behaviour to me.

Thanks,
-Fred
Reply | Threaded
Open this post in threaded view
|

Re: Edit repository doesn't save advanced settings (username / password)

Ariel
In reply to this post by Frédéric THOMAS
Hi Fred,

You can try and delete the user name and password on the Admin->Advance->"Config Descriptor"
then look for the remote repository name, and you can delete the  <username> and  <password> and then save.
Also clean cookies (if it can't help it won't do any harm... :) )

Hope that helps,
Ariel. 




On Mon, Jan 20, 2014 at 9:05 PM, Frédéric THOMAS <[hidden email]> wrote:
Hi,

I use Artifactory 3.0.4 and proxies a repo where I can't remember having set
a network username and password to access it, I manage as well this remote
repo, anyway, when I try to remove this username and password from the
advanced settings and save, artifactory doesn't save it, when I come back on
the advanced settings, the username and password are still there, other
fields are saved correctly, what am I missing ?

That's very problematic as the remote repo is set to accept anonymous
requests but having it been requested with a username and password avoid me
to download any artifacts from. [1]

I tried as well to delete and re-create the remote repo without luck, the
deletion doesn't work.

Thanks,
Frédéric THOMAS

[1]
2014-01-20 23:10:07,811 [http-bio-8085-exec-2015] [INFO ]
(o.a.c.h.a.AuthChallengeProcessor:101) - basic authentication scheme
selected
2014-01-20 23:10:07,811 [http-bio-8085-exec-2015] [INFO ]
(o.a.c.h.HttpMethodDirector:722) - Failure authenticating with BASIC
'Artifactory Realm'@apacheflexvm.cloudapp.net:80
2014-01-20 23:17:18,753 [http-bio-8085-exec-1958] [INFO ]
(o.a.w.w.a.ArtifactoryRequestCycleListener:57) - User anonymous accessed
unauthorized resource. Not authorized to instantiate class
org.artifactory.webapp.wicket.page.logs.SystemLogsPage



--
View this message in context: http://forums.jfrog.org/Edit-repository-doesn-t-save-advanced-settings-username-password-tp7579551.html
Sent from the Artifactory - Users mailing list archive at Nabble.com.

------------------------------------------------------------------------------
CenturyLink Cloud: The Leader in Enterprise Cloud Services.
Learn Why More Businesses Are Choosing CenturyLink Cloud For
Critical Workloads, Development Environments & Everything In Between.
Get a Quote or Start a Free Trial Today.
http://pubads.g.doubleclick.net/gampad/clk?id=119420431&iu=/4140/ostg.clktrk
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------
CenturyLink Cloud: The Leader in Enterprise Cloud Services.
Learn Why More Businesses Are Choosing CenturyLink Cloud For
Critical Workloads, Development Environments & Everything In Between.
Get a Quote or Start a Free Trial Today.
http://pubads.g.doubleclick.net/gampad/clk?id=119420431&iu=/4140/ostg.clktrk
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users