Issue integrating ArtifactoryPro with ActiveDirectory

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue integrating ArtifactoryPro with ActiveDirectory

Preeti_I
This post was updated on .
Hello,

I am trying to integrate ArtifactoryPro to authenticate against ActiveDirectory. I have configured the following

LDAP URL: ldap://XXX.XXX.XXX:389
User DN Pattern: sAMAccountName={0}
Email attribute: mail
Manager DN:
Manager Password: CN=XXX,OU=XXX,OU=XXX,OU=XXX,DC=XXX,DC=XXX,DC=XXX,DC=XXX

When I try to test the connection with a test username/password the authentication fails and I see the following error in the logs. Please note, the exact Manager DN and password work with our other products. The DN has a whitespace in one of the "value" fields.

[ERROR] (o.a.s.l.AbstractLdapService:59) - Authentication failed. Probably a wrong manager dn or manager password: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C0903A9, comment: AcceptSecurityContext error, data 52e, v1db1�]; nested exception is javax.naming.AuthenticationException: [LDAP: error code 49 - 80090308: LdapErr: DSID-0C0903A9, comment: AcceptSecurityContext error, data 52e, v1db1�]
Reply | Threaded
Open this post in threaded view
|

Re: Issue integrating ArtifactoryPro with ActiveDirectory

dave_p
This is what we use. (In an AD environment)

There are a few differences to yours.

The manager DN and Manager password are just the username and password
of an AD user with lookup/admin privileges.

Good luck.

On 3/18/2014 3:30 PM, Preeti_I wrote:

> Hello,
>
> I am trying to integrate ArtifactoryPro to authenticate against
> ActiveDirectory. I have configured the following
>
> LDAP URL: ldap://XXX.XXX.XXX:389
> User DN Pattern: sAMAccountName={0}
> Email attribute: mail
> Manager DN:
> Manager Password: CN=XXX,OU=XXX,OU=XXX,OU=XXX,DC=XXX,DC=XXX,DC=XXX,DC=XXX
>
> When I try to test the connection with a test username/password the
> authentication fails and I see the following error in the logs. Please note,
> the exact Manager DN and password work with our other products.
>
> [ERROR] (o.a.s.l.AbstractLdapService:59) - Authentication failed. Probably a
> wrong manager dn or manager password: [LDAP: error code 49 - 80090308:
> LdapErr: DSID-0C0903A9, comment: AcceptSecurityContext error, data 52e,
> v1db1�]; nested exception is javax.naming.AuthenticationException: [LDAP:
> error code 49 - 80090308: LdapErr: DSID-0C0903A9, comment:
> AcceptSecurityContext error, data 52e, v1db1�]
>
>
>
> --
> View this message in context: http://forums.jfrog.org/Issue-integrating-ArtifactoryPro-with-ActiveDirectory-tp7579709.html
> Sent from the Artifactory - Users mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> Learn Graph Databases - Download FREE O'Reilly Book
> "Graph Databases" is the definitive new guide to graph databases and their
> applications. Written by three acclaimed leaders in the field,
> this first edition is now available. Download your free book today!
> http://p.sf.net/sfu/13534_NeoTech
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
--
Dave Pierce
Engineering Services (MDC)
Dell | Compellent
[hidden email]

------------------------------------------------------------------------------
Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and their
applications. Written by three acclaimed leaders in the field,
this first edition is now available. Download your free book today!
http://p.sf.net/sfu/13534_NeoTech
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users

Untitled.png (34K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issue integrating ArtifactoryPro with ActiveDirectory

Preeti_I
Thank you Dave. The screenshot really helped. I re-configured my settings based on the screenshot and it works now.

Have a great day!!