Quantcast

No browsing remote repos through http proxy

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

No browsing remote repos through http proxy

PilotBlankenfelde

I've already inserted the proxy in Admin/Configuration/Proxies but without
luck.
Is there an opportunity to 'debug' the connection between Artifactory and
remote repository ?
Thank you

--
View this message in context: http://old.nabble.com/No-browsing-remote-repos-through-http-proxy-tp26495853p26495853.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No browsing remote repos through http proxy

yossis
Add the following to the logging configuration file, logback.xml under the etc directory:
    <logger name="org.apache.commons.httpclient">
        <level value="DEBUG"/>
    </logger>
It will output all the debug messages of the http client when it tries to connect to a remote repository.
Use a link similar to: http://localhost:8080/artifactory/repo1/commons-lang/commons-lang/2.4/commons-lang-2.4.jar to make artifactory connect to a remote repository.
You can then analyze the log file.

Yossi

On Tue, Nov 24, 2009 at 3:28 PM, TorstenKarusseit <[hidden email]> wrote:

I've already inserted the proxy in Admin/Configuration/Proxies but without
luck.
Is there an opportunity to 'debug' the connection between Artifactory and
remote repository ?
Thank you

--
View this message in context: http://old.nabble.com/No-browsing-remote-repos-through-http-proxy-tp26495853p26495853.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No browsing remote repos through http proxy

PilotBlankenfelde

Hi Yossi,
after changed the logback.xml
tail -f artifactory.log shows:
2009-11-25 11:18:03,098 [logback-watching] [INFO ]
(o.a.w.s.l.LogbackConfigListener$LogbackConfigWatchDog:127) - Reloaded
logback config from:
/home/pilot/Artifactory/artifactory-2.1.2/etc/logback.xml.

then I selected "repo1-cache" in Artifacts/Simple Browser and in
artifactory.log shows up nothing (!!!)

then I tried:
wget http://localhost:8081/artifactory/repo1-cache
getting:
--2009-11-25 11:30:51-- http://localhost:8081/artefactory/rep1-cache
Auflösen des Hostnamen >localhost<.... 127.0.0.1, ::1
Verbindungsaufbau zu localhost|127.0.0.1|:8081... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 302 Found
Platz: http://localhost:8081/artifactory/repo1-cache/[folge]
--2009-11-25 11:30:51-- http://localhost:8081/artifactory/repo1-cache/
Wiederverwendung der bestehenden Verbindung zu localhost:8081.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 13069 (13K) [text/html]
...
tail -f artifactory.log shows:
nothing (!!!)

Conclusions:
Artifactory does not try to connect to http://repo1.maven.org/maven2/ for
repo1-cache.
Question:
How may I debug between the following two points:
 a) selecting "repo1-cache" in Artifacts/Simple Browser and
 b) Atrifactory connecting to http://repo1.maven.org/maven2/ ?

Please tell me if I'm wrong in something.
so long
Torsten
--
View this message in context: http://old.nabble.com/No-browsing-remote-repos-through-http-proxy-tp26495853p26510641.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No browsing remote repos through http proxy

Yoav Landman
Administrator
If you are requesting a resource directly from a repository cache you will only get what has already been cached - in your case nothing, since you didn't make any remote artifact requests yet. You need to make the request to the remote repository, e.g.: http://localhost:8081/artifactory/repo1, or better, to a virtual repository URL facading other repositories, like http://localhost:8081/artifactory/remote-repos.

PS. I don't understand where the URL http://localhost:8081/artefactory/rep1-cache in your log is coming from - but it has typos.

On Wed, Nov 25, 2009 at 12:44 PM, TorstenKarusseit <[hidden email]> wrote:

Hi Yossi,
after changed the logback.xml
tail -f artifactory.log shows:
2009-11-25 11:18:03,098 [logback-watching] [INFO ]
(o.a.w.s.l.LogbackConfigListener$LogbackConfigWatchDog:127) - Reloaded
logback config from:
/home/pilot/Artifactory/artifactory-2.1.2/etc/logback.xml.

then I selected "repo1-cache" in Artifacts/Simple Browser and in
artifactory.log shows up nothing (!!!)

then I tried:
wget http://localhost:8081/artifactory/repo1-cache
getting:
--2009-11-25 11:30:51-- http://localhost:8081/artefactory/rep1-cache
Auflösen des Hostnamen >localhost<.... 127.0.0.1, ::1
Verbindungsaufbau zu localhost|127.0.0.1|:8081... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 302 Found
Platz: <a href="http://localhost:8081/artifactory/repo1-cache/[folge] --2009-11-25" target="_blank">http://localhost:8081/artifactory/repo1-cache/[folge]
--2009-11-25 11:30:51-- http://localhost:8081/artifactory/repo1-cache/
Wiederverwendung der bestehenden Verbindung zu localhost:8081.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 13069 (13K) [text/html]
...
tail -f artifactory.log shows:
nothing (!!!)

Conclusions:
Artifactory does not try to connect to http://repo1.maven.org/maven2/ for
repo1-cache.
Question:
How may I debug between the following two points:
 a) selecting "repo1-cache" in Artifacts/Simple Browser and
 b) Atrifactory connecting to http://repo1.maven.org/maven2/ ?

Please tell me if I'm wrong in something.
so long
Torsten
--
View this message in context: http://old.nabble.com/No-browsing-remote-repos-through-http-proxy-tp26495853p26510641.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users




------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No browsing remote repos through http proxy

PilotBlankenfelde

Hi Yoav,
that sounds reasonable.
I tried also http://localhost:8081/artifactory/repo1 and
http://localhost:8081/artifactory/remote-repos
with the same result.
The URL http://localhost:8081/artefactory/rep1-cache came from my first try
to connect Artifactory to the predefined repo http://repo1.maven.org/maven2/
which was wrong as you explained.
What may be the cause of not getting any successfull connection to a remote
repo ?
Do I need some add-on ?
Is there any command forcing Artifactory to connect to remote repo ?

offtopic:
You are in Admin/Reposities and you have a bit smaller window in your
browser which is scrolled down.
Then when you hover repo names the up-popping gadget is not synchronized to
your selection.

thankfull for any help
Torsten
--
View this message in context: http://old.nabble.com/No-browsing-remote-repos-through-http-proxy-tp26495853p26512714.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No browsing remote repos through http proxy

Yoav  Landman
Artifactory is a proxy - not a mirror or a remote repo browser. It does not offer auto cache population - you need to first request a remote artifact for Artifactory to cache it locally. Maven and other build tools issue artifact requests during build, causing this to happen. No connection to remote repositories is made if you only browse the cache.
As for the second issue, it'd be appreciated if you could open a jira issue (http://issues.jfrog.org), preferably with a screenshot, so we can better understand what is visually wrong on your end.

Thanks,

Yoav

On Wed, Nov 25, 2009 at 3:35 PM, TorstenKarusseit <[hidden email]> wrote:

Hi Yoav,
that sounds reasonable.
I tried also http://localhost:8081/artifactory/repo1 and
with the same result.
The URL http://localhost:8081/artefactory/rep1-cache came from my first try
to connect Artifactory to the predefined repo http://repo1.maven.org/maven2/
which was wrong as you explained.
What may be the cause of not getting any successfull connection to a remote
repo ?
Do I need some add-on ?
Is there any command forcing Artifactory to connect to remote repo ?

offtopic:
You are in Admin/Reposities and you have a bit smaller window in your
browser which is scrolled down.
Then when you hover repo names the up-popping gadget is not synchronized to
your selection.

thankfull for any help
Torsten
--
View this message in context: http://old.nabble.com/No-browsing-remote-repos-through-http-proxy-tp26495853p26512714.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users




------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: No browsing remote repos through http proxy

PilotBlankenfelde

Hi Yoav,
thank you, your last answer give me the idea:
you have to start maven (first edit settings.xml to connect to Artifactory)
to let Artifactory connect to remote repos.
Now it runs ;)

(I've posted two issues about the WebUI)

so long
Torsten

--
View this message in context: http://old.nabble.com/No-browsing-remote-repos-through-http-proxy-tp26495853p26525363.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day
trial. Simplify your report design, integration and deployment - and focus on
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Loading...