Problem deploying to Artifactory

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem deploying to Artifactory

Joserra

Hi all,

We are trying to deploy with "mvn deploy", but I get an error:

[INFO] [deploy:deploy]
[INFO] Retrieving previous build number from libs-snapshots
[INFO] repository metadata for: 'snapshot
com.biko2.can.core:host-services:1.0.1
-SNAPSHOT' could not be found on repository: libs-snapshots, so will be
created
Uploading: http://10.21.0.68:8081/artifactory/libs-snapshosts/com/biko2/can
/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.074820-1.jar
3874K uploaded
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error deploying artifact: Failed to transfer file:
http://10.21.0.68:8081
/artifactory/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHO
T/host-services-1.0.1-20090610.074820-1.jar. Return code is: 405

I hace declared in pom.xml

     <distributionManagement>
            <repository>
                <id>libs-releases</id>
         <name>mafalda.evergreen.biko2.com-releases</name>
                <url>http://10.21.0.68:8081/artifactory/libs-releases</url>
            </repository>
            <snapshotRepository>
                  <id>libs-snapshots</id>
                  <name>mafalda.evergreen.biko2.com-snapshots</name>
                  <url>http://10.21.0.68:8081/artifactory/libs-snapshosts</url>
                </snapshotRepository>
        </distributionManagement>


an in setting.xml I have also defined server, with user & passwrod. But I
don´t know what error 405 does mean.

In th e artifactory log I see:

2009-06-10 09:07:30,853 [ERROR] (o.a.w.s.RequestUtils:89) - Request
/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.080731-1.jar
should be a repo request and does not match any repo key

  But, we do have defined /libs-snapshosts as a repository...

any help would be appreciated!
--
View this message in context: http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23957639.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem deploying to Artifactory

Yossi Shaul
Looks like you are trying to deploy to a virtual repository (libs-releases), which is not allowed.
Try to deploy to libs-releases-local (or any other local repository you defined) and see if it works.

Yossi


From: Joserra <[hidden email]>
To: [hidden email]
Sent: Wednesday, June 10, 2009 11:08:26 AM
Subject: [Artifactory-users] Problem deploying to Artifactory


Hi all,

We are trying to deploy with "mvn deploy", but I get an error:

[INFO] [deploy:deploy]
[INFO] Retrieving previous build number from libs-snapshots
[INFO] repository metadata for: 'snapshot
com.biko2.can.core:host-services:1.0.1
-SNAPSHOT' could not be found on repository: libs-snapshots, so will be
created
Uploading: http://10.21.0.68:8081/artifactory/libs-snapshosts/com/biko2/can
/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.074820-1.jar
3874K uploaded
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Error deploying artifact: Failed to transfer file:
http://10.21.0.68:8081
/artifactory/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHO
T/host-services-1.0.1-20090610.074820-1.jar. Return code is: 405

I hace declared in pom.xml

    <distributionManagement>
        <repository>
            <id>libs-releases</id>
            <name>mafalda.evergreen.biko2.com-releases</name>
            http://10.21.0.68:8081/artifactory/libs-releases
        </repository>
        <snapshotRepository>
          <id>libs-snapshots</id>
          <name>mafalda.evergreen.biko2.com-snapshots</name>
          http://10.21.0.68:8081/artifactory/libs-snapshosts
        </snapshotRepository>
    </distributionManagement>


an in setting.xml I have also defined server, with user & passwrod. But I
don´t know what error 405 does mean.

In th e artifactory log I see:

2009-06-10 09:07:30,853 [ERROR] (o.a.w.s.RequestUtils:89) - Request
/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.080731-1.jar
should be a repo request and does not match any repo key

  But, we do have defined /libs-snapshosts as a repository...

any help would be appreciated!
--
View this message in context: http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23957639.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem deploying to Artifactory

Joserra

We tried it, but it´s the same

[INFO] Error deploying artifact: Failed to transfer file:
http://10.21.0.68:8081
/artifactory/libs-snapshosts-local/com/biko2/can/core/host-services/1.0.1-SNAPSH
OT/host-services-1.0.1-20090610.134137-1.jar. Return code is: 405

 Strange is that I can deploy with deploy:deploy-file to that repository
without problem.
 
  Thanks!


Yossi Shaul-2 wrote:

>
> Looks like you are trying to deploy to a virtual repository
> (libs-releases), which is not allowed.
> Try to deploy to libs-releases-local (or any other local repository you
> defined) and see if it works.
>
> Yossi
>
>
>
>
> ________________________________
> From: Joserra <[hidden email]>
> To: [hidden email]
> Sent: Wednesday, June 10, 2009 11:08:26 AM
> Subject: [Artifactory-users]  Problem deploying to Artifactory
>
>
> Hi all,
>
> We are trying to deploy with "mvn deploy", but I get an error:
>
> [INFO] [deploy:deploy]
> [INFO] Retrieving previous build number from libs-snapshots
> [INFO] repository metadata for: 'snapshot
> com.biko2.can.core:host-services:1.0.1
> -SNAPSHOT' could not be found on repository: libs-snapshots, so will be
> created
> Uploading:
> http://10.21.0.68:8081/artifactory/libs-snapshosts/com/biko2/can
> /core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.074820-1.jar
> 3874K uploaded
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error deploying artifact: Failed to transfer file:
> http://10.21.0.68:8081
> /artifactory/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHO
> T/host-services-1.0.1-20090610.074820-1.jar. Return code is: 405
>
> I hace declared in pom.xml
>
>      <distributionManagement>
>         <repository>
>             <id>libs-releases</id>
>             <name>mafalda.evergreen.biko2.com-releases</name>
>             http://10.21.0.68:8081/artifactory/libs-releases
>         </repository>
>         <snapshotRepository>
>           <id>libs-snapshots</id>
>           <name>mafalda.evergreen.biko2.com-snapshots</name>
>           http://10.21.0.68:8081/artifactory/libs-snapshosts
>         </snapshotRepository>
>     </distributionManagement>
>
>
> an in setting.xml I have also defined server, with user & passwrod. But I
> don´t know what error 405 does mean.
>
> In th e artifactory log I see:
>
> 2009-06-10 09:07:30,853 [ERROR] (o.a.w.s.RequestUtils:89) - Request
> /libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.080731-1.jar
> should be a repo request and does not match any repo key
>
>   But, we do have defined /libs-snapshosts as a repository...
>
> any help would be appreciated!
> --
> View this message in context:
> http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23957639.html
> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>
>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>

--
View this message in context: http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23962618.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem deploying to Artifactory

Yossi Shaul
Do you pass repository id to the deploy:deploy-file goal? if you do, is it the same one you used in the distribution management?


From: Joserra <[hidden email]>
To: [hidden email]
Sent: Wednesday, June 10, 2009 4:44:10 PM
Subject: Re: [Artifactory-users] Problem deploying to Artifactory


We tried it, but it´s the same

[INFO] Error deploying artifact: Failed to transfer file:
http://10.21.0.68:8081
/artifactory/libs-snapshosts-local/com/biko2/can/core/host-services/1.0.1-SNAPSH
OT/host-services-1.0.1-20090610.134137-1.jar. Return code is: 405

Strange is that I can deploy with deploy:deploy-file to that repository
without problem.

  Thanks!


Yossi Shaul-2 wrote:

>
> Looks like you are trying to deploy to a virtual repository
> (libs-releases), which is not allowed.
> Try to deploy to libs-releases-local (or any other local repository you
> defined) and see if it works.
>
> Yossi
>
>
>
>
> ________________________________
> From: Joserra <[hidden email]>
> To: [hidden email]
> Sent: Wednesday, June 10, 2009 11:08:26 AM
> Subject: [Artifactory-users]  Problem deploying to Artifactory
>
>
> Hi all,
>
> We are trying to deploy with "mvn deploy", but I get an error:
>
> [INFO] [deploy:deploy]
> [INFO] Retrieving previous build number from libs-snapshots
> [INFO] repository metadata for: 'snapshot
> com.biko2.can.core:host-services:1.0.1
> -SNAPSHOT' could not be found on repository: libs-snapshots, so will be
> created
> Uploading:
> http://10.21.0.68:8081/artifactory/libs-snapshosts/com/biko2/can

> /core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.074820-1.jar
> 3874K uploaded
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error deploying artifact: Failed to transfer file:
> http://10.21.0.68:8081
> /artifactory/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHO
> T/host-services-1.0.1-20090610.074820-1.jar. Return code is: 405
>
> I hace declared in pom.xml
>
>      <distributionManagement>
>        <repository>
>            <id>libs-releases</id>
>            <name>mafalda.evergreen.biko2.com-releases</name>
>            http://10.21.0.68:8081/artifactory/libs-releases
>        </repository>
>        <snapshotRepository>
>          <id>libs-snapshots</id>
>          <name>mafalda.evergreen.biko2.com-snapshots</name>
>          http://10.21.0.68:8081/artifactory/libs-snapshosts

>        </snapshotRepository>
>    </distributionManagement>
>
>
> an in setting.xml I have also defined server, with user & passwrod. But I
> don´t know what error 405 does mean.
>
> In th e artifactory log I see:
>
> 2009-06-10 09:07:30,853 [ERROR] (o.a.w.s.RequestUtils:89) - Request
> /libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.080731-1.jar
> should be a repo request and does not match any repo key
>
>  But, we do have defined /libs-snapshosts as a repository...
>
> any help would be appreciated!
> --
> View this message in context:
> http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23957639.html
> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects

> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>
>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>

--
View this message in context: http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23962618.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem deploying to Artifactory

Joserra
Yes, the same :(

On Wed, Jun 10, 2009 at 4:32 PM, Yossi Shaul <[hidden email]> wrote:
Do you pass repository id to the deploy:deploy-file goal? if you do, is it the same one you used in the distribution management?


From: Joserra <[hidden email]>
To: [hidden email]
Sent: Wednesday, June 10, 2009 4:44:10 PM
Subject: Re: [Artifactory-users] Problem deploying to Artifactory


We tried it, but it´s the same

[INFO] Error deploying artifact: Failed to transfer file:
http://10.21.0.68:8081
/artifactory/libs-snapshosts-local/com/biko2/can/core/host-services/1.0.1-SNAPSH
OT/host-services-1.0.1-20090610.134137-1.jar. Return code is: 405

Strange is that I can deploy with deploy:deploy-file to that repository
without problem.

  Thanks!


Yossi Shaul-2 wrote:
>
> Looks like you are trying to deploy to a virtual repository
> (libs-releases), which is not allowed.
> Try to deploy to libs-releases-local (or any other local repository you
> defined) and see if it works.
>
> Yossi
>
>
>
>
> ________________________________
> From: Joserra <[hidden email]>
> To: [hidden email]
> Sent: Wednesday, June 10, 2009 11:08:26 AM
> Subject: [Artifactory-users]  Problem deploying to Artifactory
>
>
> Hi all,
>
> We are trying to deploy with "mvn deploy", but I get an error:
>
> [INFO] [deploy:deploy]
> [INFO] Retrieving previous build number from libs-snapshots
> [INFO] repository metadata for: 'snapshot
> com.biko2.can.core:host-services:1.0.1
> -SNAPSHOT' could not be found on repository: libs-snapshots, so will be
> created
> Uploading:
> http://10.21.0.68:8081/artifactory/libs-snapshosts/com/biko2/can
> /core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.074820-1.jar
> 3874K uploaded
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error deploying artifact: Failed to transfer file:
> http://10.21.0.68:8081
> /artifactory/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHO
> T/host-services-1.0.1-20090610.074820-1.jar. Return code is: 405
>
> I hace declared in pom.xml
>
>      <distributionManagement>
>        <repository>
>            <id>libs-releases</id>
>            <name>mafalda.evergreen.biko2.com-releases</name>
>            http://10.21.0.68:8081/artifactory/libs-releases
>        </repository>
>        <snapshotRepository>
>          <id>libs-snapshots</id>
>          <name>mafalda.evergreen.biko2.com-snapshots</name>
>          http://10.21.0.68:8081/artifactory/libs-snapshosts
>        </snapshotRepository>
>    </distributionManagement>
>
>
> an in setting.xml I have also defined server, with user & passwrod. But I
> don´t know what error 405 does mean.
>
> In th e artifactory log I see:
>
> 2009-06-10 09:07:30,853 [ERROR] (o.a.w.s.RequestUtils:89) - Request
> /libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.080731-1.jar
> should be a repo request and does not match any repo key
>
>  But, we do have defined /libs-snapshosts as a repository...
>
> any help would be appreciated!
> --
> View this message in context:
> http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23957639.html
> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>
>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>

--
View this message in context: http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23962618.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem deploying to Artifactory

Yoav Landman
Administrator
Odd, as we normally return 405 only for certain WebDav requests, which from to the info you provided, is not being used.
Can you turn on the DEBUG level on org.artifactory.webapp.servlet.RepoFilter (etc/logback.xml) and see if you get more relevant details?
Also, if you can provide your artifactory.config.xml (privately if you wish), it might help us point you at the right direction.

Thanks,

Yoav

On Wed, Jun 10, 2009 at 5:39 PM, Jose R. <[hidden email]> wrote:
Yes, the same :(


On Wed, Jun 10, 2009 at 4:32 PM, Yossi Shaul <[hidden email]> wrote:
Do you pass repository id to the deploy:deploy-file goal? if you do, is it the same one you used in the distribution management?


From: Joserra <[hidden email]>
To: [hidden email]
Sent: Wednesday, June 10, 2009 4:44:10 PM
Subject: Re: [Artifactory-users] Problem deploying to Artifactory


We tried it, but it´s the same

[INFO] Error deploying artifact: Failed to transfer file:
http://10.21.0.68:8081
/artifactory/libs-snapshosts-local/com/biko2/can/core/host-services/1.0.1-SNAPSH
OT/host-services-1.0.1-20090610.134137-1.jar. Return code is: 405

Strange is that I can deploy with deploy:deploy-file to that repository
without problem.

  Thanks!


Yossi Shaul-2 wrote:
>
> Looks like you are trying to deploy to a virtual repository
> (libs-releases), which is not allowed.
> Try to deploy to libs-releases-local (or any other local repository you
> defined) and see if it works.
>
> Yossi
>
>
>
>
> ________________________________
> From: Joserra <[hidden email]>
> To: [hidden email]
> Sent: Wednesday, June 10, 2009 11:08:26 AM
> Subject: [Artifactory-users]  Problem deploying to Artifactory
>
>
> Hi all,
>
> We are trying to deploy with "mvn deploy", but I get an error:
>
> [INFO] [deploy:deploy]
> [INFO] Retrieving previous build number from libs-snapshots
> [INFO] repository metadata for: 'snapshot
> com.biko2.can.core:host-services:1.0.1
> -SNAPSHOT' could not be found on repository: libs-snapshots, so will be
> created
> Uploading:
> http://10.21.0.68:8081/artifactory/libs-snapshosts/com/biko2/can
> /core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.074820-1.jar
> 3874K uploaded
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error deploying artifact: Failed to transfer file:
> http://10.21.0.68:8081
> /artifactory/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHO
> T/host-services-1.0.1-20090610.074820-1.jar. Return code is: 405
>
> I hace declared in pom.xml
>
>      <distributionManagement>
>        <repository>
>            <id>libs-releases</id>
>            <name>mafalda.evergreen.biko2.com-releases</name>
>            http://10.21.0.68:8081/artifactory/libs-releases
>        </repository>
>        <snapshotRepository>
>          <id>libs-snapshots</id>
>          <name>mafalda.evergreen.biko2.com-snapshots</name>
>          http://10.21.0.68:8081/artifactory/libs-snapshosts
>        </snapshotRepository>
>    </distributionManagement>
>
>
> an in setting.xml I have also defined server, with user & passwrod. But I
> don´t know what error 405 does mean.
>
> In th e artifactory log I see:
>
> 2009-06-10 09:07:30,853 [ERROR] (o.a.w.s.RequestUtils:89) - Request
> /libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.080731-1.jar
> should be a repo request and does not match any repo key
>
>  But, we do have defined /libs-snapshosts as a repository...
>
> any help would be appreciated!
> --
> View this message in context:
> http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23957639.html
> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>
>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>

--
View this message in context: http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23962618.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem deploying to Artifactory

Joserra

Yoav pointed me the error.

Just, the first thing to check is that the repo name matches the one in the
deployment URL. I had simply a typo error.

Thanks!


Yoav  Landman wrote:

>
> Odd, as we normally return 405 only for certain WebDav requests, which
> from
> to the info you provided, is not being used.
> Can you turn on the DEBUG level on
> org.artifactory.webapp.servlet.RepoFilter
> (etc/logback.xml) and see if you get more relevant details?
> Also, if you can provide your artifactory.config.xml (privately if you
> wish), it might help us point you at the right direction.
>
> Thanks,
>
> Yoav
>
> On Wed, Jun 10, 2009 at 5:39 PM, Jose R. <[hidden email]> wrote:
>
>> Yes, the same :(
>>
>>
>> On Wed, Jun 10, 2009 at 4:32 PM, Yossi Shaul
>> <[hidden email]>wrote:
>>
>>> Do you pass repository id to the deploy:deploy-file goal? if you do, is
>>> it
>>> the same one you used in the distribution management?
>>>
>>> ------------------------------
>>> *From:* Joserra <[hidden email]>
>>> *To:* [hidden email]
>>> *Sent:* Wednesday, June 10, 2009 4:44:10 PM
>>> *Subject:* Re: [Artifactory-users] Problem deploying to Artifactory
>>>
>>>
>>> We tried it, but it´s the same
>>>
>>> [INFO] Error deploying artifact: Failed to transfer file:
>>> http://10.21.0.68:8081
>>>
>>> /artifactory/libs-snapshosts-local/com/biko2/can/core/host-services/1.0.1-SNAPSH
>>> OT/host-services-1.0.1-20090610.134137-1.jar. Return code is: 405
>>>
>>> Strange is that I can deploy with deploy:deploy-file to that repository
>>> without problem.
>>>
>>>   Thanks!
>>>
>>>
>>> Yossi Shaul-2 wrote:
>>> >
>>> > Looks like you are trying to deploy to a virtual repository
>>> > (libs-releases), which is not allowed.
>>> > Try to deploy to libs-releases-local (or any other local repository
>>> you
>>> > defined) and see if it works.
>>> >
>>> > Yossi
>>> >
>>> >
>>> >
>>> >
>>> > ________________________________
>>> > From: Joserra <[hidden email]>
>>> > To: [hidden email]
>>> > Sent: Wednesday, June 10, 2009 11:08:26 AM
>>> > Subject: [Artifactory-users]  Problem deploying to Artifactory
>>> >
>>> >
>>> > Hi all,
>>> >
>>> > We are trying to deploy with "mvn deploy", but I get an error:
>>> >
>>> > [INFO] [deploy:deploy]
>>> > [INFO] Retrieving previous build number from libs-snapshots
>>> > [INFO] repository metadata for: 'snapshot
>>> > com.biko2.can.core:host-services:1.0.1
>>> > -SNAPSHOT' could not be found on repository: libs-snapshots, so will
>>> be
>>> > created
>>> > Uploading:
>>> > http://10.21.0.68:8081/artifactory/libs-snapshosts/com/biko2/can
>>> >
>>> /core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.074820-1.jar
>>> > 3874K uploaded
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [ERROR] BUILD ERROR
>>> > [INFO]
>>> >
>>> ------------------------------------------------------------------------
>>> > [INFO] Error deploying artifact: Failed to transfer file:
>>> > http://10.21.0.68:8081
>>> >
>>> /artifactory/libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHO
>>> > T/host-services-1.0.1-20090610.074820-1.jar. Return code is: 405
>>> >
>>> > I hace declared in pom.xml
>>> >
>>> >      <distributionManagement>
>>> >        <repository>
>>> >            <id>libs-releases</id>
>>> >            <name>mafalda.evergreen.biko2.com-releases</name>
>>> >            http://10.21.0.68:8081/artifactory/libs-releases
>>> >        </repository>
>>> >        <snapshotRepository>
>>> >          <id>libs-snapshots</id>
>>> >          <name>mafalda.evergreen.biko2.com-snapshots</name>
>>> >          http://10.21.0.68:8081/artifactory/libs-snapshosts
>>> >        </snapshotRepository>
>>> >    </distributionManagement>
>>> >
>>> >
>>> > an in setting.xml I have also defined server, with user & passwrod.
>>> But
>>> I
>>> > don´t know what error 405 does mean.
>>> >
>>> > In th e artifactory log I see:
>>> >
>>> > 2009-06-10 09:07:30,853 [ERROR] (o.a.w.s.RequestUtils:89) - Request
>>> >
>>> /libs-snapshosts/com/biko2/can/core/host-services/1.0.1-SNAPSHOT/host-services-1.0.1-20090610.080731-1.jar
>>> > should be a repo request and does not match any repo key
>>> >
>>> >  But, we do have defined /libs-snapshosts as a repository...
>>> >
>>> > any help would be appreciated!
>>> > --
>>> > View this message in context:
>>> >
>>> http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23957639.html
>>> > Sent from the Artifactory-Users mailing list archive at Nabble.com.
>>> >
>>> >
>>> >
>>> ------------------------------------------------------------------------------
>>> > Crystal Reports - New Free Runtime and 30 Day Trial
>>> > Check out the new simplified licensing option that enables unlimited
>>> > royalty-free distribution of the report engine for externally facing
>>> > server and web deployment.
>>> > http://p.sf.net/sfu/businessobjects
>>> > _______________________________________________
>>> > Artifactory-users mailing list
>>> > [hidden email]
>>> > https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>> >
>>> >
>>> >
>>> >
>>> >
>>> ------------------------------------------------------------------------------
>>> > Crystal Reports - New Free Runtime and 30 Day Trial
>>> > Check out the new simplified licensing option that enables unlimited
>>> > royalty-free distribution of the report engine for externally facing
>>> > server and web deployment.
>>> > http://p.sf.net/sfu/businessobjects
>>> > _______________________________________________
>>> > Artifactory-users mailing list
>>> > [hidden email]
>>> > https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>> >
>>> >
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p23962618.html
>>> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>>>
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> Crystal Reports - New Free Runtime and 30 Day Trial
>>> Check out the new simplified licensing option that enables unlimited
>>> royalty-free distribution of the report engine for externally facing
>>> server and web deployment.
>>> http://p.sf.net/sfu/businessobjects
>>> _______________________________________________
>>> Artifactory-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>>
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> Crystal Reports - New Free Runtime and 30 Day Trial
>>> Check out the new simplified licensing option that enables unlimited
>>> royalty-free distribution of the report engine for externally facing
>>> server and web deployment.
>>> http://p.sf.net/sfu/businessobjects
>>> _______________________________________________
>>> Artifactory-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>>
>>>
>>
>>
>> ------------------------------------------------------------------------------
>> Crystal Reports - New Free Runtime and 30 Day Trial
>> Check out the new simplified licensing option that enables unlimited
>> royalty-free distribution of the report engine for externally facing
>> server and web deployment.
>> http://p.sf.net/sfu/businessobjects
>> _______________________________________________
>> Artifactory-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>
>>
>
> ------------------------------------------------------------------------------
> Crystal Reports - New Free Runtime and 30 Day Trial
> Check out the new simplified licensing option that enables unlimited
> royalty-free distribution of the report engine for externally facing
> server and web deployment.
> http://p.sf.net/sfu/businessobjects
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>

--
View this message in context: http://www.nabble.com/Problem-deploying-to-Artifactory-tp23957639p24070956.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Crystal Reports - New Free Runtime and 30 Day Trial
Check out the new simplified licensing option that enables unlimited
royalty-free distribution of the report engine for externally facing
server and web deployment.
http://p.sf.net/sfu/businessobjects
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users