SNAPSHOT-problems

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

SNAPSHOT-problems

André Velle

Hi,

I've recently set up artifactory for my company, and followed the standard
setup. It's working fine for caching requests to external repositories,
including our own. I also tried to set up a local snapshot repository in
artifactory. When I deploy snapshots to this (using the http address of the
repo in the repository definition) the artifacts end up with the names like
<artifactname>-1.2-SNAPSHOT-SNAPSHOT.jar

Any clues to what I'm doing wrong???

-André
--
View this message in context: http://www.nabble.com/SNAPSHOT-problems-tf3485706.html#a9731006
Sent from the Artifactory-Users mailing list archive at Nabble.com.



Reply | Threaded
Open this post in threaded view
|

Re: SNAPSHOT-problems

Thorsten Heit
Hi André,

> I've recently set up artifactory for my company, and followed the standard
> setup. It's working fine for caching requests to external repositories,
> including our own. I also tried to set up a local snapshot repository in
> artifactory. When I deploy snapshots to this (using the http address of
> the
> repo in the repository definition) the artifacts end up with the names
> like
> <artifactname>-1.2-SNAPSHOT-SNAPSHOT.jar

I assume you have already checked that your pom.xml is correct...?

Have you configured separate repositories for releases and snapshots in your artifactory.config.xml or do you use only one? I'm using the following configuration that works quite fine for me:


<localRepositories>
  <localRepository>
    <key>local-repo</key>
    <description>Local Releasess</description>
    <handleReleases>true</handleReleases>
    <handleSnapshots>false</handleSnapshots>
  </localRepository>
  <localRepository>
    <key>local-snapshots</key>
    <description>Local Snapshots</description>
    <handleReleases>false</handleReleases>
    <handleSnapshots>true</handleSnapshots>
  </localRepository>
</localRepositories>


HTH

Thorsten


Reply | Threaded
Open this post in threaded view
|

Re: SNAPSHOT-problems

André Velle



Thorsten Heit-3 wrote:

>
> Hi André,
>
>> I've recently set up artifactory for my company, and followed the
>> standard
>> setup. It's working fine for caching requests to external repositories,
>> including our own. I also tried to set up a local snapshot repository in
>> artifactory. When I deploy snapshots to this (using the http address of
>> the
>> repo in the repository definition) the artifacts end up with the names
>> like
>> <artifactname>-1.2-SNAPSHOT-SNAPSHOT.jar
>
> I assume you have already checked that your pom.xml is correct...?
>
> Have you configured separate repositories for releases and snapshots in
> your artifactory.config.xml or do you use only one? I'm using the
> following configuration that works quite fine for me:
>
>
> <localRepositories>
>   <localRepository>
>     <key>local-repo</key>
>     <description>Local Releasess</description>
>     <handleReleases>true</handleReleases>
>     <handleSnapshots>false</handleSnapshots>
>   </localRepository>
>   <localRepository>
>     <key>local-snapshots</key>
>     <description>Local Snapshots</description>
>     <handleReleases>false</handleReleases>
>     <handleSnapshots>true</handleSnapshots>
>   </localRepository>
> </localRepositories>
>
>
> HTH
>
> Thorsten
>
>

Hi Thorsten,

Thanks for the answer!
Except for the names of the repositories, that's exactly what I have
configured. The pom is unchanged (except for repository the address)  from
one that worked fine for a ssh-based deploy:

...
    <distributionManagement>
       
<downloadUrl>http://iplutv.netcom.no:6666/artifactory/repo</downloadUrl>
        <repository>
            <uniqueVersion>false</uniqueVersion>
            <id>netcom-releases</id>
           
<url>http://iplutv.netcom.no:6666/artifactory/netcom-releases</url>
        </repository>
        <snapshotRepository>
            <uniqueVersion>false</uniqueVersion>
                        <id>netcom-snapshots</id>
                        <url>http://iplutv.netcom.no:6666/artifactory/netcom-snapshots</url>
        </snapshotRepository>
    </distributionManagement>
...

-André

--
View this message in context: http://www.nabble.com/SNAPSHOT-problems-tf3485706.html#a9732013
Sent from the Artifactory-Users mailing list archive at Nabble.com.



Reply | Threaded
Open this post in threaded view
|

Re: SNAPSHOT-problems

Yoav Landman
Administrator
It is a bug. Thanks for reporting this.

We allow for central per-repository management of whether snapshots will have unique versions or not (having a unique version for a snapshot that is constantly deployed can fill up a repository pretty quickly, so it's normally something that a repository manager wants to have control over). This can be done with the "useSnapshotUniqueVersions" flag, which is true by default.
We will probably have to add "user" as a new valid setting (for "useSnapshotUniqueVersions") to allow controlling the unique version from user's POM as well. I created: https://www.jfrog.org/jira/browse/RTFACT-96

For now, just remove the <uniqueVersion>false</uniqueVersion>and everything should work fine.

On 3/29/07, André Velle <[hidden email]> wrote:



Thorsten Heit-3 wrote:

>
> Hi André,
>
>> I've recently set up artifactory for my company, and followed the
>> standard
>> setup. It's working fine for caching requests to external repositories,
>> including our own. I also tried to set up a local snapshot repository in
>> artifactory. When I deploy snapshots to this (using the http address of
>> the
>> repo in the repository definition) the artifacts end up with the names
>> like
>> <artifactname>-1.2-SNAPSHOT-SNAPSHOT.jar
>
> I assume you have already checked that your pom.xml is correct...?
>
> Have you configured separate repositories for releases and snapshots in
> your artifactory.config.xml or do you use only one? I'm using the
> following configuration that works quite fine for me:
>
>
> <localRepositories>
>   <localRepository>
>     <key>local-repo</key>
>     <description>Local Releasess</description>
>     <handleReleases>true</handleReleases>
>     <handleSnapshots>false</handleSnapshots>
>   </localRepository>
>   <localRepository>
>     <key>local-snapshots</key>
>     <description>Local Snapshots</description>
>     <handleReleases>false</handleReleases>
>     <handleSnapshots>true</handleSnapshots>
>   </localRepository>
> </localRepositories>
>
>
> HTH
>
> Thorsten
>
>

Hi Thorsten,

Thanks for the answer!
Except for the names of the repositories, that's exactly what I have
configured. The pom is unchanged (except for repository the address)  from
one that worked fine for a ssh-based deploy:

...
    <distributionManagement>

<downloadUrl>http://iplutv.netcom.no:6666/artifactory/repo</downloadUrl>
        <repository>
            <uniqueVersion>false</uniqueVersion>
            <id>netcom-releases</id>

<url>http://iplutv.netcom.no:6666/artifactory/netcom-releases </url>
        </repository>
        <snapshotRepository>
            <uniqueVersion>false</uniqueVersion>
                        <id>netcom-snapshots</id>
                        <url> http://iplutv.netcom.no:6666/artifactory/netcom-snapshots</url>
        </snapshotRepository>
    </distributionManagement>
...

-André

--
View this message in context: http://www.nabble.com/SNAPSHOT-problems-tf3485706.html#a9732013
Sent from the Artifactory-Users mailing list archive at Nabble.com.


-------------------------------------------------------------------------
Take Surveys. Earn Cash. Influence the Future of IT
Join SourceForge.net's Techsay panel and you'll get the chance to share your
opinions on IT & business topics through brief surveys-and earn cash
http://www.techsay.com/default.php?page=join.php&p=sourceforge&CID=DEVDEV
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users

Reply | Threaded
Open this post in threaded view
|

Re: SNAPSHOT-problems

André Velle

That worked, thanks

-André



Yoav  Landman wrote:

>
> It is a bug. Thanks for reporting this.
>
> We allow for central per-repository management of whether snapshots will
> have unique versions or not (having a unique version for a snapshot that
> is
> constantly deployed can fill up a repository pretty quickly, so it's
> normally something that a repository manager wants to have control over).
> This can be done with the "useSnapshotUniqueVersions" flag, which is true
> by
> default.
> We will probably have to add "user" as a new valid setting (for
> "useSnapshotUniqueVersions") to allow controlling the unique version from
> user's POM as well. I created: https://www.jfrog.org/jira/browse/RTFACT-96
>
> For now, just remove the <uniqueVersion>false</uniqueVersion>and
> everything
> should work fine.
>

--
View this message in context: http://www.nabble.com/SNAPSHOT-problems-tf3485706.html#a9733348
Sent from the Artifactory-Users mailing list archive at Nabble.com.