The host did not accept the connection within timeout

classic Classic list List threaded Threaded
5 messages Options
mv2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

The host did not accept the connection within timeout

mv2

Hi,

I have installed Artifactory v2.0.6 and using it with Maven 2.0.9, and Java
1.6.0_14.

Artifactory is installed behind firewall. I have set the proxy in
Admin->Configuration->Proxy as:
Proxy-Key: some_key
Host: proxy.company.com
Port: 80
Username: <Left it blank>
Password: <Left it blank>
NT Host: <Left it blank>
NT Domain: <Left it blank>

When I try to use any maven command such as 'mvn clean', I get the following
errors:

*********************************
2009-06-25 10:10:32,238 [DEBUG]
(o.a.c.h.MultiThreadedHttpConnectionManager:839) - Getting free connection,
hostConfig=HostConfiguration[host=http://repo1.maven.org]
2009-06-25 10:10:32,238 [DEBUG] (o.a.c.h.HttpConnection:692) - Open
connection to repo1.maven.org:80
2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:404) - Closing
the connection.
2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:434) - Method
retry handler returned false. Automatic recovery will not be attempted
2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpConnection:1178) - Releasing
connection back to connection manager.
2009-06-25 10:10:47,285 [DEBUG]
(o.a.c.h.MultiThreadedHttpConnectionManager:979) - Freeing connection,
hostConfig=HostConfiguration[host=http://repo1.maven.org]
2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.u.IdleConnectionHandler:76) -
Adding connection at: 1245939047285
2009-06-25 10:10:47,285 [DEBUG]
(o.a.c.h.MultiThreadedHttpConnectionManager:961) - Notifying no-one, there
are no waiting threads
2009-06-25 10:10:47,301 [WARN ] (o.a.r.RemoteRepoBase:199) - repo1: Error in
getting information for
'org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom'
(Failed retrieving resource from
http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom:
The host did not accept the connection within timeout of 15000 ms).
*********************************

I even tried using '-Dhttp.proxyHost=proxy.company.com -Dhttp.proxyPort=80'
when starting the Jetty server but still getting the same error.

I am able to run all Maven commands successfully when I remove Artifactory
repositories i.e. if I directly go to http://repo1.maven.org with proxy set
in settings.xml file.

Here is my setting.xml file with Artifactory:

**********************************
<settings>
    <profiles>
        <profile>
            <id>development</id>
                                <repositories>
                                        <repository>
                                                <id>central</id>
                                                <url>http://localhost:8081/artifactory/repo/</url>
                                                <snapshots>
                                                        <enabled>false</enabled>
                                                </snapshots>
                                        </repository>
                                        <repository>
                                                <id>snapshots</id>
                                                <url>http://localhost:8081/artifactory/repo/</url>
                                                <releases>
                                                        <enabled>false</enabled>
                                                </releases>
                                        </repository>
                                </repositories>
                               
                                <pluginRepositories>
                                        <pluginRepository>
                                                <id>central</id>
                                                <url>http://localhost:8081/artifactory/plugins-releases/</url>
                                                <snapshots>
                                                        <enabled>false</enabled>
                                                </snapshots>
                                        </pluginRepository>
                                        <pluginRepository>
                                                <id>snapshots</id>
                                                <url>http://localhost:8081/artifactory/plugins-snapshots/</url>
                                                <releases>
                                                        <enabled>false</enabled>
                                                </releases>
                                        </pluginRepository>
                                </pluginRepositories>
        </profile>
    </profiles>
       
    <activeProfiles>
        <activeProfile>development</activeProfile>
    </activeProfiles>
       
</settings>
**********************************

Any suggestions?

Thanks.
-M



--
View this message in context: http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24204504.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: The host did not accept the connection within timeout

Yoav Landman
Administrator
Is your proxy an NTLM proxy?


On Thu, Jun 25, 2009 at 5:38 PM, mv2 <[hidden email]> wrote:

Hi,

I have installed Artifactory v2.0.6 and using it with Maven 2.0.9, and Java
1.6.0_14.

Artifactory is installed behind firewall. I have set the proxy in
Admin->Configuration->Proxy as:
Proxy-Key: some_key
Host: proxy.company.com
Port: 80
Username: <Left it blank>
Password: <Left it blank>
NT Host: <Left it blank>
NT Domain: <Left it blank>

When I try to use any maven command such as 'mvn clean', I get the following
errors:

*********************************
2009-06-25 10:10:32,238 [DEBUG]
(o.a.c.h.MultiThreadedHttpConnectionManager:839) - Getting free connection,
hostConfig=HostConfiguration[host=http://repo1.maven.org]
2009-06-25 10:10:32,238 [DEBUG] (o.a.c.h.HttpConnection:692) - Open
connection to repo1.maven.org:80
2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:404) - Closing
the connection.
2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:434) - Method
retry handler returned false. Automatic recovery will not be attempted
2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpConnection:1178) - Releasing
connection back to connection manager.
2009-06-25 10:10:47,285 [DEBUG]
(o.a.c.h.MultiThreadedHttpConnectionManager:979) - Freeing connection,
hostConfig=HostConfiguration[host=http://repo1.maven.org]
2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.u.IdleConnectionHandler:76) -
Adding connection at: 1245939047285
2009-06-25 10:10:47,285 [DEBUG]
(o.a.c.h.MultiThreadedHttpConnectionManager:961) - Notifying no-one, there
are no waiting threads
2009-06-25 10:10:47,301 [WARN ] (o.a.r.RemoteRepoBase:199) - repo1: Error in
getting information for
'org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom'
(Failed retrieving resource from
http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom:
The host did not accept the connection within timeout of 15000 ms).
*********************************

I even tried using '-Dhttp.proxyHost=proxy.company.com -Dhttp.proxyPort=80'
when starting the Jetty server but still getting the same error.

I am able to run all Maven commands successfully when I remove Artifactory
repositories i.e. if I directly go to http://repo1.maven.org with proxy set
in settings.xml file.

Here is my setting.xml file with Artifactory:

**********************************
<settings>
   <profiles>
       <profile>
           <id>development</id>
                               <repositories>
                                       <repository>
                                               <id>central</id>
                                               <url>http://localhost:8081/artifactory/repo/</url>
                                               <snapshots>
                                                       <enabled>false</enabled>
                                               </snapshots>
                                       </repository>
                                       <repository>
                                               <id>snapshots</id>
                                               <url>http://localhost:8081/artifactory/repo/</url>
                                               <releases>
                                                       <enabled>false</enabled>
                                               </releases>
                                       </repository>
                               </repositories>

                               <pluginRepositories>
                                       <pluginRepository>
                                               <id>central</id>
                                               <url>http://localhost:8081/artifactory/plugins-releases/</url>
                                               <snapshots>
                                                       <enabled>false</enabled>
                                               </snapshots>
                                       </pluginRepository>
                                       <pluginRepository>
                                               <id>snapshots</id>
                                               <url>http://localhost:8081/artifactory/plugins-snapshots/</url>
                                               <releases>
                                                       <enabled>false</enabled>
                                               </releases>
                                       </pluginRepository>
                               </pluginRepositories>
       </profile>
   </profiles>

   <activeProfiles>
       <activeProfile>development</activeProfile>
   </activeProfiles>

</settings>
**********************************

Any suggestions?

Thanks.
-M



--
View this message in context: http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24204504.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
mv2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: The host did not accept the connection within timeout

mv2


Hi Yoav,

I don't know if it is NTLM proxy. Is there any command to find out?

Specifying '-Dhttp.proxyHost=proxy.company.com-Dhttp.proxyPort=80' in Java
works all the times.

In browser 'proxy.company.com:80' always works.

Even in Maven settings.xml file, specifying only 'proxy.company.com' works.

Thanks.



Yoav  Landman wrote:

>
> Is your proxy an NTLM proxy?
>
>
> On Thu, Jun 25, 2009 at 5:38 PM, mv2 <[hidden email]> wrote:
>
>>
>> Hi,
>>
>> I have installed Artifactory v2.0.6 and using it with Maven 2.0.9, and
>> Java
>> 1.6.0_14.
>>
>> Artifactory is installed behind firewall. I have set the proxy in
>> Admin->Configuration->Proxy as:
>> Proxy-Key: some_key
>> Host: proxy.company.com
>> Port: 80
>> Username: <Left it blank>
>> Password: <Left it blank>
>> NT Host: <Left it blank>
>> NT Domain: <Left it blank>
>>
>> When I try to use any maven command such as 'mvn clean', I get the
>> following
>> errors:
>>
>> *********************************
>> 2009-06-25 10:10:32,238 [DEBUG]
>> (o.a.c.h.MultiThreadedHttpConnectionManager:839) - Getting free
>> connection,
>> hostConfig=HostConfiguration[host=http://repo1.maven.org]
>> 2009-06-25 10:10:32,238 [DEBUG] (o.a.c.h.HttpConnection:692) - Open
>> connection to repo1.maven.org:80
>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:404) -
>> Closing
>> the connection.
>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:434) - Method
>> retry handler returned false. Automatic recovery will not be attempted
>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpConnection:1178) - Releasing
>> connection back to connection manager.
>> 2009-06-25 10:10:47,285 [DEBUG]
>> (o.a.c.h.MultiThreadedHttpConnectionManager:979) - Freeing connection,
>> hostConfig=HostConfiguration[host=http://repo1.maven.org]
>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.u.IdleConnectionHandler:76) -
>> Adding connection at: 1245939047285
>> 2009-06-25 10:10:47,285 [DEBUG]
>> (o.a.c.h.MultiThreadedHttpConnectionManager:961) - Notifying no-one,
>> there
>> are no waiting threads
>> 2009-06-25 10:10:47,301 [WARN ] (o.a.r.RemoteRepoBase:199) - repo1: Error
>> in
>> getting information for
>>
>> 'org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom'
>> (Failed retrieving resource from
>>
>> http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom
>> :
>> The host did not accept the connection within timeout of 15000 ms).
>> *********************************
>>
>> I even tried using
>> '-Dhttp.proxyHost=proxy.company.com-Dhttp.proxyPort=80'
>> when starting the Jetty server but still getting the same error.
>>
>> I am able to run all Maven commands successfully when I remove
>> Artifactory
>> repositories i.e. if I directly go to http://repo1.maven.org with proxy
>> set
>> in settings.xml file.
>>
>> Here is my setting.xml file with Artifactory:
>>
>> **********************************
>> <settings>
>>    <profiles>
>>        <profile>
>>            <id>development</id>
>>                                <repositories>
>>                                        <repository>
>>                                                <id>central</id>
>>                                                <url>
>> http://localhost:8081/artifactory/repo/</url>
>>                                                <snapshots>
>>
>>  <enabled>false</enabled>
>>                                                </snapshots>
>>                                        </repository>
>>                                        <repository>
>>                                                <id>snapshots</id>
>>                                                <url>
>> http://localhost:8081/artifactory/repo/</url>
>>                                                <releases>
>>
>>  <enabled>false</enabled>
>>                                                </releases>
>>                                        </repository>
>>                                </repositories>
>>
>>                                <pluginRepositories>
>>                                        <pluginRepository>
>>                                                <id>central</id>
>>                                                <url>
>> http://localhost:8081/artifactory/plugins-releases/</url>
>>                                                <snapshots>
>>
>>  <enabled>false</enabled>
>>                                                </snapshots>
>>                                        </pluginRepository>
>>                                        <pluginRepository>
>>                                                <id>snapshots</id>
>>                                                <url>
>> http://localhost:8081/artifactory/plugins-snapshots/</url>
>>                                                <releases>
>>
>>  <enabled>false</enabled>
>>                                                </releases>
>>                                        </pluginRepository>
>>                                </pluginRepositories>
>>        </profile>
>>    </profiles>
>>
>>    <activeProfiles>
>>        <activeProfile>development</activeProfile>
>>    </activeProfiles>
>>
>> </settings>
>> **********************************
>>
>> Any suggestions?
>>
>> Thanks.
>> -M
>>
>>
>>
>> --
>> View this message in context:
>> http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24204504.html
>> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>>
>>
>>
>> ------------------------------------------------------------------------------
>> _______________________________________________
>> Artifactory-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>
>
> ------------------------------------------------------------------------------
>
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>

--
View this message in context: http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24211935.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: The host did not accept the connection within timeout

Frederic Simon
I did not see if you configured the remote repository to use this
configured proxy?
Can you verify in the remote repo configuration dialog that the proxy
combobox point to it?

HTH,
Fred.
On 6/26/09, mv2 <[hidden email]> wrote:

>
>
> Hi Yoav,
>
> I don't know if it is NTLM proxy. Is there any command to find out?
>
> Specifying '-Dhttp.proxyHost=proxy.company.com-Dhttp.proxyPort=80' in Java
> works all the times.
>
> In browser 'proxy.company.com:80' always works.
>
> Even in Maven settings.xml file, specifying only 'proxy.company.com' works.
>
> Thanks.
>
>
>
> Yoav  Landman wrote:
>>
>> Is your proxy an NTLM proxy?
>>
>>
>> On Thu, Jun 25, 2009 at 5:38 PM, mv2 <[hidden email]> wrote:
>>
>>>
>>> Hi,
>>>
>>> I have installed Artifactory v2.0.6 and using it with Maven 2.0.9, and
>>> Java
>>> 1.6.0_14.
>>>
>>> Artifactory is installed behind firewall. I have set the proxy in
>>> Admin->Configuration->Proxy as:
>>> Proxy-Key: some_key
>>> Host: proxy.company.com
>>> Port: 80
>>> Username: <Left it blank>
>>> Password: <Left it blank>
>>> NT Host: <Left it blank>
>>> NT Domain: <Left it blank>
>>>
>>> When I try to use any maven command such as 'mvn clean', I get the
>>> following
>>> errors:
>>>
>>> *********************************
>>> 2009-06-25 10:10:32,238 [DEBUG]
>>> (o.a.c.h.MultiThreadedHttpConnectionManager:839) - Getting free
>>> connection,
>>> hostConfig=HostConfiguration[host=http://repo1.maven.org]
>>> 2009-06-25 10:10:32,238 [DEBUG] (o.a.c.h.HttpConnection:692) - Open
>>> connection to repo1.maven.org:80
>>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:404) -
>>> Closing
>>> the connection.
>>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:434) - Method
>>> retry handler returned false. Automatic recovery will not be attempted
>>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpConnection:1178) - Releasing
>>> connection back to connection manager.
>>> 2009-06-25 10:10:47,285 [DEBUG]
>>> (o.a.c.h.MultiThreadedHttpConnectionManager:979) - Freeing connection,
>>> hostConfig=HostConfiguration[host=http://repo1.maven.org]
>>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.u.IdleConnectionHandler:76) -
>>> Adding connection at: 1245939047285
>>> 2009-06-25 10:10:47,285 [DEBUG]
>>> (o.a.c.h.MultiThreadedHttpConnectionManager:961) - Notifying no-one,
>>> there
>>> are no waiting threads
>>> 2009-06-25 10:10:47,301 [WARN ] (o.a.r.RemoteRepoBase:199) - repo1: Error
>>> in
>>> getting information for
>>>
>>> 'org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom'
>>> (Failed retrieving resource from
>>>
>>> http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom
>>> :
>>> The host did not accept the connection within timeout of 15000 ms).
>>> *********************************
>>>
>>> I even tried using
>>> '-Dhttp.proxyHost=proxy.company.com-Dhttp.proxyPort=80'
>>> when starting the Jetty server but still getting the same error.
>>>
>>> I am able to run all Maven commands successfully when I remove
>>> Artifactory
>>> repositories i.e. if I directly go to http://repo1.maven.org with proxy
>>> set
>>> in settings.xml file.
>>>
>>> Here is my setting.xml file with Artifactory:
>>>
>>> **********************************
>>> <settings>
>>>    <profiles>
>>>        <profile>
>>>            <id>development</id>
>>>                                <repositories>
>>>                                        <repository>
>>>                                                <id>central</id>
>>>                                                <url>
>>> http://localhost:8081/artifactory/repo/</url>
>>>                                                <snapshots>
>>>
>>>  <enabled>false</enabled>
>>>                                                </snapshots>
>>>                                        </repository>
>>>                                        <repository>
>>>                                                <id>snapshots</id>
>>>                                                <url>
>>> http://localhost:8081/artifactory/repo/</url>
>>>                                                <releases>
>>>
>>>  <enabled>false</enabled>
>>>                                                </releases>
>>>                                        </repository>
>>>                                </repositories>
>>>
>>>                                <pluginRepositories>
>>>                                        <pluginRepository>
>>>                                                <id>central</id>
>>>                                                <url>
>>> http://localhost:8081/artifactory/plugins-releases/</url>
>>>                                                <snapshots>
>>>
>>>  <enabled>false</enabled>
>>>                                                </snapshots>
>>>                                        </pluginRepository>
>>>                                        <pluginRepository>
>>>                                                <id>snapshots</id>
>>>                                                <url>
>>> http://localhost:8081/artifactory/plugins-snapshots/</url>
>>>                                                <releases>
>>>
>>>  <enabled>false</enabled>
>>>                                                </releases>
>>>                                        </pluginRepository>
>>>                                </pluginRepositories>
>>>        </profile>
>>>    </profiles>
>>>
>>>    <activeProfiles>
>>>        <activeProfile>development</activeProfile>
>>>    </activeProfiles>
>>>
>>> </settings>
>>> **********************************
>>>
>>> Any suggestions?
>>>
>>> Thanks.
>>> -M
>>>
>>>
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24204504.html
>>> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>>>
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> _______________________________________________
>>> Artifactory-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>>
>>
>> ------------------------------------------------------------------------------
>>
>> _______________________________________________
>> Artifactory-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>
>>
>
> --
> View this message in context:
> http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24211935.html
> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>


--
JFrog Ltd
5 Habonim st., P.O.Box 8187
Netanya, Israel 42504.
Tel: +972 9 8941444
Fax: +972 9 8659977
http://www.jfrog.org/
http://freddy33.blogspot.com/
http://nothingisinfinite.blogspot.com/

------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
mv2
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: The host did not accept the connection within timeout

mv2

Hi Fred,

That was it!! Everything is working now. I completely overlooked the Proxy
combo box. Thank you very much!!!

-M



freddy33 wrote:

>
> I did not see if you configured the remote repository to use this
> configured proxy?
> Can you verify in the remote repo configuration dialog that the proxy
> combobox point to it?
>
> HTH,
> Fred.
> On 6/26/09, mv2 <[hidden email]> wrote:
>>
>>
>> Hi Yoav,
>>
>> I don't know if it is NTLM proxy. Is there any command to find out?
>>
>> Specifying '-Dhttp.proxyHost=proxy.company.com-Dhttp.proxyPort=80' in
>> Java
>> works all the times.
>>
>> In browser 'proxy.company.com:80' always works.
>>
>> Even in Maven settings.xml file, specifying only 'proxy.company.com'
>> works.
>>
>> Thanks.
>>
>>
>>
>> Yoav  Landman wrote:
>>>
>>> Is your proxy an NTLM proxy?
>>>
>>>
>>> On Thu, Jun 25, 2009 at 5:38 PM, mv2 <[hidden email]> wrote:
>>>
>>>>
>>>> Hi,
>>>>
>>>> I have installed Artifactory v2.0.6 and using it with Maven 2.0.9, and
>>>> Java
>>>> 1.6.0_14.
>>>>
>>>> Artifactory is installed behind firewall. I have set the proxy in
>>>> Admin->Configuration->Proxy as:
>>>> Proxy-Key: some_key
>>>> Host: proxy.company.com
>>>> Port: 80
>>>> Username: <Left it blank>
>>>> Password: <Left it blank>
>>>> NT Host: <Left it blank>
>>>> NT Domain: <Left it blank>
>>>>
>>>> When I try to use any maven command such as 'mvn clean', I get the
>>>> following
>>>> errors:
>>>>
>>>> *********************************
>>>> 2009-06-25 10:10:32,238 [DEBUG]
>>>> (o.a.c.h.MultiThreadedHttpConnectionManager:839) - Getting free
>>>> connection,
>>>> hostConfig=HostConfiguration[host=http://repo1.maven.org]
>>>> 2009-06-25 10:10:32,238 [DEBUG] (o.a.c.h.HttpConnection:692) - Open
>>>> connection to repo1.maven.org:80
>>>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:404) -
>>>> Closing
>>>> the connection.
>>>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpMethodDirector:434) -
>>>> Method
>>>> retry handler returned false. Automatic recovery will not be attempted
>>>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.HttpConnection:1178) -
>>>> Releasing
>>>> connection back to connection manager.
>>>> 2009-06-25 10:10:47,285 [DEBUG]
>>>> (o.a.c.h.MultiThreadedHttpConnectionManager:979) - Freeing connection,
>>>> hostConfig=HostConfiguration[host=http://repo1.maven.org]
>>>> 2009-06-25 10:10:47,285 [DEBUG] (o.a.c.h.u.IdleConnectionHandler:76) -
>>>> Adding connection at: 1245939047285
>>>> 2009-06-25 10:10:47,285 [DEBUG]
>>>> (o.a.c.h.MultiThreadedHttpConnectionManager:961) - Notifying no-one,
>>>> there
>>>> are no waiting threads
>>>> 2009-06-25 10:10:47,301 [WARN ] (o.a.r.RemoteRepoBase:199) - repo1:
>>>> Error
>>>> in
>>>> getting information for
>>>>
>>>> 'org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom'
>>>> (Failed retrieving resource from
>>>>
>>>> http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-clean-plugin/2.2/maven-clean-plugin-2.2.pom
>>>> :
>>>> The host did not accept the connection within timeout of 15000 ms).
>>>> *********************************
>>>>
>>>> I even tried using
>>>> '-Dhttp.proxyHost=proxy.company.com-Dhttp.proxyPort=80'
>>>> when starting the Jetty server but still getting the same error.
>>>>
>>>> I am able to run all Maven commands successfully when I remove
>>>> Artifactory
>>>> repositories i.e. if I directly go to http://repo1.maven.org with proxy
>>>> set
>>>> in settings.xml file.
>>>>
>>>> Here is my setting.xml file with Artifactory:
>>>>
>>>> **********************************
>>>> <settings>
>>>>    <profiles>
>>>>        <profile>
>>>>            <id>development</id>
>>>>                                <repositories>
>>>>                                        <repository>
>>>>                                                <id>central</id>
>>>>                                                <url>
>>>> http://localhost:8081/artifactory/repo/</url>
>>>>                                                <snapshots>
>>>>
>>>>  <enabled>false</enabled>
>>>>                                                </snapshots>
>>>>                                        </repository>
>>>>                                        <repository>
>>>>                                                <id>snapshots</id>
>>>>                                                <url>
>>>> http://localhost:8081/artifactory/repo/</url>
>>>>                                                <releases>
>>>>
>>>>  <enabled>false</enabled>
>>>>                                                </releases>
>>>>                                        </repository>
>>>>                                </repositories>
>>>>
>>>>                                <pluginRepositories>
>>>>                                        <pluginRepository>
>>>>                                                <id>central</id>
>>>>                                                <url>
>>>> http://localhost:8081/artifactory/plugins-releases/</url>
>>>>                                                <snapshots>
>>>>
>>>>  <enabled>false</enabled>
>>>>                                                </snapshots>
>>>>                                        </pluginRepository>
>>>>                                        <pluginRepository>
>>>>                                                <id>snapshots</id>
>>>>                                                <url>
>>>> http://localhost:8081/artifactory/plugins-snapshots/</url>
>>>>                                                <releases>
>>>>
>>>>  <enabled>false</enabled>
>>>>                                                </releases>
>>>>                                        </pluginRepository>
>>>>                                </pluginRepositories>
>>>>        </profile>
>>>>    </profiles>
>>>>
>>>>    <activeProfiles>
>>>>        <activeProfile>development</activeProfile>
>>>>    </activeProfiles>
>>>>
>>>> </settings>
>>>> **********************************
>>>>
>>>> Any suggestions?
>>>>
>>>> Thanks.
>>>> -M
>>>>
>>>>
>>>>
>>>> --
>>>> View this message in context:
>>>> http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24204504.html
>>>> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>>>>
>>>>
>>>>
>>>> ------------------------------------------------------------------------------
>>>> _______________________________________________
>>>> Artifactory-users mailing list
>>>> [hidden email]
>>>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>>>
>>>
>>> ------------------------------------------------------------------------------
>>>
>>> _______________________________________________
>>> Artifactory-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>>
>>>
>>
>> --
>> View this message in context:
>> http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24211935.html
>> Sent from the Artifactory-Users mailing list archive at Nabble.com.
>>
>>
>> ------------------------------------------------------------------------------
>> _______________________________________________
>> Artifactory-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>>
>
>
> --
> JFrog Ltd
> 5 Habonim st., P.O.Box 8187
> Netanya, Israel 42504.
> Tel: +972 9 8941444
> Fax: +972 9 8659977
> http://www.jfrog.org/
> http://freddy33.blogspot.com/
> http://nothingisinfinite.blogspot.com/
>
> ------------------------------------------------------------------------------
> _______________________________________________
> Artifactory-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/artifactory-users
>
>

--
View this message in context: http://www.nabble.com/The-host-did-not-accept-the-connection-within-timeout-tp24204504p24218341.html
Sent from the Artifactory-Users mailing list archive at Nabble.com.


------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Loading...