Very slow LDAP login

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Very slow LDAP login

Shrike
Hi.

We have Artifactory 4.0.2 on Windows under Apache. Recently we start experiencing very slow operating of Artifactory. It seems that the reason is slowness of LDAP connections. On "Edit LDAP settings" page I run "Test LDAP connection" (under the same account as Artifactory goes into LDAP) and it takes more than 2 minutes! It's huge.
From the server where Artifactory is running I can easily access our LDAP (MS Active Directory) server via SysInternal's ADExplorer and it browses it pretty fast. So the problem is not in our LDAP.

What can be wrong with our Artifactory-LDAP connectivity?


ps:
java x64 1.8.0_60
Reply | Threaded
Open this post in threaded view
|

Re: Very slow LDAP login

shayb

Hi Shrike,


Usually, when there is no ‘Search Base’ configured for the Artifactory LDAP integration, or if the ‘Search Base’ is too wide, the LDAP search can be slow (depending on the network and the size of the LDAP server). This is because without a search base, Artifactory searches over the entire LDAP tree.


Search Base - The Context name in which to search relative to the base DN in the LDAP URL. This is parameter is optional. (taken from JFrog’s documentations)


In order to improve the search performance, you should set a Search Base (Narrow as possible) for a specific area which includes all of your requirements, but still not cause Artifactory to search over the entire tree, or search over many irrelevant OU's etc..


Shay.


On Tue, Oct 6, 2015 at 2:10 PM, Shrike [via Artifactory] <[hidden email]> wrote:
Hi.

We have Artifactory 4.0.2 on Windows under Apache. Recently we start experiencing very slow operating of Artifactory. It seems that the reason is slowness of LDAP connections. On "Edit LDAP settings" page I run "Test LDAP connection" (under the same account as Artifactory goes into LDAP) and it takes more than 2 minutes! It's huge.
From the server where Artifactory is running I can easily access our LDAP (MS Active Directory) server via SysInternal's ADExplorer and it browses it pretty fast. So the problem is not in our LDAP.

What can be wrong with our Artifactory-LDAP connectivity?


ps:
java x64 1.8.0_60


If you reply to this email, your message will be added to the discussion below:
http://forums.jfrog.org/Very-slow-LDAP-login-tp7580505.html
To start a new topic under Artifactory - Users, email [hidden email]
To unsubscribe from Artifactory, click here.
NAML