Why this msg? "Artifactory Tomcat server did not start in 60 seconds. Please check the logs"

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Why this msg? "Artifactory Tomcat server did not start in 60 seconds. Please check the logs"

gomex
After fresh installation of Artifactory, using this doc[1], I did started the service and I got this error:

"Artifactory Tomcat server did not start in 60 seconds. Please check the logs"

I checked the logs:

root@debian:~# tail -f /srv/artifactory/logs/artifactory.log
2014-08-15 15:18:05,087 [art-init] [INFO ] (o.a.s.ArtifactoryApplicationContext:221) - Initializing org.artifactory.repo.cleanup.InternalVirtualCacheCleanupService
2014-08-15 15:18:05,089 [art-init] [INFO ] (o.a.s.ArtifactoryApplicationContext:221) - Initializing org.artifactory.maven.index.InternalMavenIndexerService
2014-08-15 15:18:05,090 [art-init] [INFO ] (o.a.s.ArtifactoryApplicationContext:221) - Initializing org.artifactory.storage.db.servers.service.ArtifactoryHeartbeatService
2014-08-15 15:18:05,091 [art-init] [INFO ] (o.a.s.ArtifactoryApplicationContext:221) - Initializing org.artifactory.security.interceptor.SecurityConfigurationChangesInterceptors
2014-08-15 15:18:05,123 [art-init] [INFO ] (o.a.s.ArtifactoryApplicationContext:359) - Artifactory application context is ready.
2014-08-15 15:18:05,125 [art-init] [INFO ] (o.a.w.s.ArtifactoryContextConfigListener:225) -
###########################################################
### Artifactory successfully started (14.469 seconds)   ###
###########################################################

Artifactory started in 14.469 seconds and works well, why this msg?

[1] - http://www.jfrog.com/confluence/display/RTF/Installing+on+Linux+Solaris+or+Mac+OS#InstallingonLinuxSolarisorMacOS-ServiceInstallation
Reply | Threaded
Open this post in threaded view
|

Re: Why this msg? "Artifactory Tomcat server did not start in 60 seconds. Please check the logs"

Ariel
Hi Rafael,

From the snippet it seems that you looked on the artifactory.log.
Try looking in the $TOMCAT_HOME/logs/catalina.out and the localhost.log if there are any clues for this message. 

This message is usually related to the tomcat rather than the Artifactory itself.

You can post here the issue, in case that there is one, from those logs and I'll try to assist in analysing it. 

Ariel.


On Fri, Aug 15, 2014 at 9:24 PM, gomex <[hidden email]> wrote:
After fresh installation of Artifactory, using this doc[1], I did started the
service and I got this error:

"Artifactory Tomcat server did not start in 60 seconds. Please check the
logs"

I checked the logs:

root@debian:~# tail -f /srv/artifactory/logs/artifactory.log
2014-08-15 15:18:05,087 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.repo.cleanup.InternalVirtualCacheCleanupService
2014-08-15 15:18:05,089 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.maven.index.InternalMavenIndexerService
2014-08-15 15:18:05,090 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.storage.db.servers.service.ArtifactoryHeartbeatService
2014-08-15 15:18:05,091 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.security.interceptor.SecurityConfigurationChangesInterceptors
2014-08-15 15:18:05,123 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:359) - Artifactory application context
is ready.
2014-08-15 15:18:05,125 [art-init] [INFO ]
(o.a.w.s.ArtifactoryContextConfigListener:225) -
###########################################################
### Artifactory successfully started (14.469 seconds)   ###
###########################################################

Artifactory started in 14.469 seconds and works well, why this msg?

[1] -
http://www.jfrog.com/confluence/display/RTF/Installing+on+Linux+Solaris+or+Mac+OS#InstallingonLinuxSolarisorMacOS-ServiceInstallation



--
View this message in context: http://forums.jfrog.org/Why-this-msg-Artifactory-Tomcat-server-did-not-start-in-60-seconds-Please-check-the-logs-tp7579945.html
Sent from the Artifactory - Users mailing list archive at Nabble.com.

------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Why this msg? "Artifactory Tomcat server did not start in 60 seconds. Please check the logs"

gomex
Hi Ariel,

Here is my logs:


And localhost :

root@debian:~# cat /srv/artifactory/tomcat/logs/localhost.2014-08-18.log
Ago 18, 2014 9:35:27 AM org.apache.catalina.core.ApplicationContext log
INFORMAÇÕES: Using artifactory.home at '/srv/artifactory' resolved from: System property

Rafael Brito Gomes
Universidade Federal da Bahia - UFBA
Arquiteto de Soluções
Superintendência de Tecnologia da Informação - STI
Tel.: (71) 3283-5679


De: "Ariel Seftel" <[hidden email]>
Para: [hidden email]
Enviadas: Domingo, 17 de agosto de 2014 15:34:47
Assunto: Re: [Artifactory-users] Why this msg? "Artifactory Tomcat server did not start in 60 seconds. Please check the logs"

Hi Rafael,

From the snippet it seems that you looked on the artifactory.log.
Try looking in the $TOMCAT_HOME/logs/catalina.out and the localhost.log if there are any clues for this message. 

This message is usually related to the tomcat rather than the Artifactory itself.

You can post here the issue, in case that there is one, from those logs and I'll try to assist in analysing it. 

Ariel.


On Fri, Aug 15, 2014 at 9:24 PM, gomex <[hidden email]> wrote:
After fresh installation of Artifactory, using this doc[1], I did started the
service and I got this error:

"Artifactory Tomcat server did not start in 60 seconds. Please check the
logs"

I checked the logs:

root@debian:~# tail -f /srv/artifactory/logs/artifactory.log
2014-08-15 15:18:05,087 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.repo.cleanup.InternalVirtualCacheCleanupService
2014-08-15 15:18:05,089 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.maven.index.InternalMavenIndexerService
2014-08-15 15:18:05,090 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.storage.db.servers.service.ArtifactoryHeartbeatService
2014-08-15 15:18:05,091 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.security.interceptor.SecurityConfigurationChangesInterceptors
2014-08-15 15:18:05,123 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:359) - Artifactory application context
is ready.
2014-08-15 15:18:05,125 [art-init] [INFO ]
(o.a.w.s.ArtifactoryContextConfigListener:225) -
###########################################################
### Artifactory successfully started (14.469 seconds)   ###
###########################################################

Artifactory started in 14.469 seconds and works well, why this msg?

[1] -
http://www.jfrog.com/confluence/display/RTF/Installing+on+Linux+Solaris+or+Mac+OS#InstallingonLinuxSolarisorMacOS-ServiceInstallation



--
View this message in context: http://forums.jfrog.org/Why-this-msg-Artifactory-Tomcat-server-did-not-start-in-60-seconds-Please-check-the-logs-tp7579945.html
Sent from the Artifactory - Users mailing list archive at Nabble.com.

------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: Why this msg? "Artifactory Tomcat server did not start in 60 seconds. Please check the logs"

Ariel
Hi Rafael,

From the logs it seems that the process was up and running in under 60 secs. This can be a logging issue.

I believe this can be safely ignored.

Ariel.  


On Mon, Aug 18, 2014 at 3:49 PM, Rafael Brito Gomes <[hidden email]> wrote:
Hi Ariel,

Here is my logs:


And localhost :

root@debian:~# cat /srv/artifactory/tomcat/logs/localhost.2014-08-18.log
Ago 18, 2014 9:35:27 AM org.apache.catalina.core.ApplicationContext log
INFORMAÇÕES: Using artifactory.home at '/srv/artifactory' resolved from: System property

Rafael Brito Gomes
Universidade Federal da Bahia - UFBA
Arquiteto de Soluções
Superintendência de Tecnologia da Informação - STI
Tel.: (71) 3283-5679


De: "Ariel Seftel" <[hidden email]>
Para: [hidden email]
Enviadas: Domingo, 17 de agosto de 2014 15:34:47
Assunto: Re: [Artifactory-users] Why this msg? "Artifactory Tomcat server did not start in 60 seconds. Please check the logs"


Hi Rafael,

From the snippet it seems that you looked on the artifactory.log.
Try looking in the $TOMCAT_HOME/logs/catalina.out and the localhost.log if there are any clues for this message. 

This message is usually related to the tomcat rather than the Artifactory itself.

You can post here the issue, in case that there is one, from those logs and I'll try to assist in analysing it. 

Ariel.


On Fri, Aug 15, 2014 at 9:24 PM, gomex <[hidden email]> wrote:
After fresh installation of Artifactory, using this doc[1], I did started the
service and I got this error:

"Artifactory Tomcat server did not start in 60 seconds. Please check the
logs"

I checked the logs:

root@debian:~# tail -f /srv/artifactory/logs/artifactory.log
2014-08-15 15:18:05,087 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.repo.cleanup.InternalVirtualCacheCleanupService
2014-08-15 15:18:05,089 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.maven.index.InternalMavenIndexerService
2014-08-15 15:18:05,090 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.storage.db.servers.service.ArtifactoryHeartbeatService
2014-08-15 15:18:05,091 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:221) - Initializing
org.artifactory.security.interceptor.SecurityConfigurationChangesInterceptors
2014-08-15 15:18:05,123 [art-init] [INFO ]
(o.a.s.ArtifactoryApplicationContext:359) - Artifactory application context
is ready.
2014-08-15 15:18:05,125 [art-init] [INFO ]
(o.a.w.s.ArtifactoryContextConfigListener:225) -
###########################################################
### Artifactory successfully started (14.469 seconds)   ###
###########################################################

Artifactory started in 14.469 seconds and works well, why this msg?

[1] -
http://www.jfrog.com/confluence/display/RTF/Installing+on+Linux+Solaris+or+Mac+OS#InstallingonLinuxSolarisorMacOS-ServiceInstallation



--
View this message in context: http://forums.jfrog.org/Why-this-msg-Artifactory-Tomcat-server-did-not-start-in-60-seconds-Please-check-the-logs-tp7579945.html
Sent from the Artifactory - Users mailing list archive at Nabble.com.

------------------------------------------------------------------------------
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users



------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users