Yum Install gets 404 Errors on Remote Yum Repo in Artifactory

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Yum Install gets 404 Errors on Remote Yum Repo in Artifactory

alexlaverty
I am currently running an instance of Artifactory Professional 4.0.2 rev 40009 on Windows Server 2008 R2.

I have configured https://mirror.aarnet.edu.au as a remote Yum repository in Artifactory.

I have configured yum on a linux server to point to this artifactory instance.

When I run the command :

yum install -y epel-release

I get 404 errors like this :

epel/7/x86_64/updateinfo       FAILED
http://<Artifactory Server Instance>/artifactory/mirror.aarnet.edu.au/pub/epel/7/x86_64/repodata/0dd9044655fe1722d6579c768395f719a74f9954cf78e80d0b757a313be4f7e2-updateinfo.xml.bz2: [Errno 14] HTTP Error 404 - Not Found|    0 B  --:--:-- ETA Trying other mirror.

If I browse the url directly I get a similar 404 error :

{
    "errors" : [ {
    "status" : 404,
    "message" : "Not Found"
    } ]
}

Here is the remote Yum Repo Configuration in Artifactory :

<remoteRepository>
        <key>mirror.aarnet.edu.au</key>
        <type>yum</type>
        <description>Mirror of Yum packages hosted by mirror.aarnet.edu.au</description>
        <includesPattern>pub/centos/**,epel/**,pub/epel/**,pub/elrepo/**,pub/el6-dom0/**,pub/fedora/**,pub/fedora-secondary/**,</includesPattern>
        <repoLayoutRef>simple-default</repoLayoutRef>
        <dockerApiVersion>V1</dockerApiVersion>
        <forceDockerAuthentication>false</forceDockerAuthentication>
        <blackedOut>false</blackedOut>
        <handleReleases>true</handleReleases>
        <handleSnapshots>true</handleSnapshots>
        <maxUniqueSnapshots>0</maxUniqueSnapshots>
        <suppressPomConsistencyChecks>true</suppressPomConsistencyChecks>
        <propertySets>
            <propertySetRef>artifactory</propertySetRef>
        </propertySets>
        <archiveBrowsingEnabled>false</archiveBrowsingEnabled>
        <url>https://mirror.aarnet.edu.au</url>
        <offline>false</offline>
        <hardFail>false</hardFail>
        <storeArtifactsLocally>true</storeArtifactsLocally>
        <fetchJarsEagerly>false</fetchJarsEagerly>
        <fetchSourcesEagerly>false</fetchSourcesEagerly>
        <retrievalCachePeriodSecs>0</retrievalCachePeriodSecs>
        <assumedOfflinePeriodSecs>300</assumedOfflinePeriodSecs>
        <missedRetrievalCachePeriodSecs>7200</missedRetrievalCachePeriodSecs>
        <remoteRepoChecksumPolicyType>generate-if-absent</remoteRepoChecksumPolicyType>
        <unusedArtifactsCleanupPeriodHours>24</unusedArtifactsCleanupPeriodHours>
        <shareConfiguration>false</shareConfiguration>
        <synchronizeProperties>false</synchronizeProperties>
        <listRemoteFolderItems>true</listRemoteFolderItems>
        <rejectInvalidJars>false</rejectInvalidJars>
        <allowAnyHostAuth>false</allowAnyHostAuth>
        <socketTimeoutMillis>15000</socketTimeoutMillis>
        <enableCookieManagement>false</enableCookieManagement>
        <enableTokenAuthentication>false</enableTokenAuthentication>
        <proxyRef>Developer-Proxy</proxyRef>
</remoteRepository>

Here is the Yum Repo Configuration :

[epel]
name=Extra Packages for Enterprise Linux 7 - $basearch
baseurl=http://<artifactory server instance>/artifactory/mirror.aarnet.edu.au/pub/epel/$releasever/$basearch/
failovermethod=priority
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7

[epel-debuginfo]
name=Extra Packages for Enterprise Linux 7 - $basearch - Debug
baseurl=http://<artifactory server instance>/artifactory/mirror.aarnet.edu.au/pub/epel/$releasever/$basearch/debug
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1

[epel-source]
name=Extra Packages for Enterprise Linux 7 - $basearch - Source
baseurl=http://<artifactory server instance>/artifactory/mirror.aarnet.edu.au/pub/epel/$releasever/SRPMS
failovermethod=priority
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-7
gpgcheck=1

How do I fix this issue?