docker remote (Docker Hub) : proxy not used for auth.docker.io

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

docker remote (Docker Hub) : proxy not used for auth.docker.io

Alix Lourme

Hi,

 

On Artifactory v4.3.2, a docker remote repository (on “Docker Hub”) seems not use the proxy configured in advanced tab.

 

Consider a simple docker configuration like doc : docker-local & docker-remote (behing company proxy) & docker-virtual (entry point).

 

This scenario works and validate the installation (internet proxy configured for docker deamon, for this sample … the objective is to use Artifactory as proxy)

$ docker pull busybox

$ docker tag busybox repository.company.com/test

$ docker push repository.company.com/test

$ docker images -aq | xargs docker rmi –f

$ docker pull repository.company.com/test

 

But trying using Artifactory as registry proxy for official images:

$ docker pull repository.company.com/ubuntu

 

Gives : “FATA[0001] Error: Status 400 trying to pull repository ubuntu: "{\n  \"errors\" : [ {\n    \"status\" : 400,\n    \"message\" : \"Unsupported docker v1 repository request for 'docker'\"\n  } ]\n}"”

 

In Artifactory log :

---

2015-12-16 14:42:28,001 [ajp-nio-8019-exec-4] [DEBUG] (o.a.u.PreemptiveAuthInterceptor:59) - Updating credentials for host https://registry-1.docker.io

2015-12-16 14:42:29,173 [ajp-nio-8019-exec-4] [ERROR] (o.a.a.d.r.DockerTokenProvider:183) - Error occurred while retrieving token from 'https://auth.docker.io/token?scope=repository:library/ubuntu:pull&service=registry.docker.io': auth.docker.io: unknown error

2015-12-16 14:42:29,182 [ajp-nio-8019-exec-4] [DEBUG] (o.a.a.d.r.DockerTokenProvider:184) - Error occurred while retrieving token from 'https://auth.docker.io/token?scope=repository:library/ubuntu:pull&service=registry.docker.io'.

java.net.UnknownHostException: auth.docker.io: unknown error

                at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method) ~[na:1.8.0_60]

---

 

=> The internet proxy configured for docker-remote (here: https://registry-1.docker.io/) seems not used for “sub call”, like https://auth.docker.io

 

Workaround: Configuring the proxy as “System Default” solve the problem, but has some impacts on company domain requests (“no hosts” can’t be configured on the proxy).

 

Best regards.

Alix


------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: [#34834] docker remote (Docker Hub) : proxy not used for auth.docker.io

JFrog Support
Hello Alix,

Thank you for contacting us. As an Artifactory Pro Enterprise customer, you can always contact JFrog Support directly at [hidden email], forums.jfrog.org is generally for Artifactory OSS users.

In order for us to better understand this issue, could you please provide us with the following information:
1. The full artifactory.log and request.log at $ARTIFACTORY_HOME/logs . Before sending the log files please add these loggers:
<logger name="org.artifactory.repo.HttpRepo">
<level value="debug"/>
</logger>
<logger name="org.artifactory.addon.docker">
<level value="debug"/>
</logger>
<logger name="org.artifactory.engine.DownloadService">
<level value="debug"/>
</logger>

These loggers should be added to $ARTIFACTORY_HOME/etc/logback.xml before reproducing this issue. Please note that there is no need to restart Artifactory after adding the loggers. Only to reproduce the issue.

2. The proxy server's configuration
3. The Artifactory and Docker client versions

Since this problem is fixed by setting a ‘System Default’ proxy in Artifactory, you may be experiencing this bug, however we would like to examine your logs to confirm.

Best Regards,
Omar
JFrog Support 
 
On Wed, 16 Dec at 11:03 AM , Alix Lourme <[hidden email]> wrote:
Hi,
 
On Artifactory v4.3.2, a docker remote repository (on “Docker Hub”) seems not use the proxy configured in advanced tab.
 
Consider a simple docker configuration like doc : docker-local & docker-remote (behing company proxy) & docker-virtual (entry point).
 
This scenario works and validate the installation (internet proxy configured for docker deamon, for this sample … the objective is to use Artifactory as proxy)
$ docker pull busybox
$ docker tag busybox repository.company.com/test
$ docker push repository.company.com/test
$ docker images -aq | xargs docker rmi –f
$ docker pull repository.company.com/test
 
But trying using Artifactory as registry proxy for official images:
$ docker pull repository.company.com/ubuntu
 
Gives : “FATA[0001] Error: Status 400 trying to pull repository ubuntu: "{\n  \"errors\" : [ {\n    \"status\" : 400,\n    \"message\" : \"Unsupported docker v1 repository request for 'docker'\"\n  } ]\n}"”
 
In Artifactory log :
---
2015-12-16 14:42:28,001 [ajp-nio-8019-exec-4] [DEBUG] (o.a.u.PreemptiveAuthInterceptor:59) - Updating credentials for host https://registry-1.docker.io
2015-12-16 14:42:29,173 [ajp-nio-8019-exec-4] [ERROR] (o.a.a.d.r.DockerTokenProvider:183) - Error occurred while retrieving token from 'https://auth.docker.io/token?scope=repository:library/ubuntu:pull&service=registry.docker.io': auth.docker.io: unknown error
2015-12-16 14:42:29,182 [ajp-nio-8019-exec-4] [DEBUG] (o.a.a.d.r.DockerTokenProvider:184) - Error occurred while retrieving token from 'https://auth.docker.io/token?scope=repository:library/ubuntu:pull&service=registry.docker.io'.
java.net.UnknownHostException: auth.docker.io: unknown error
                at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method) ~[na:1.8.0_60]
---
 
=> The internet proxy configured for docker-remote (here: https://registry-1.docker.io/) seems not used for “sub call”, like https://auth.docker.io
 
Workaround: Configuring the proxy as “System Default” solve the problem, but has some impacts on company domain requests (“no hosts” can’t be configured on the proxy).
 
Best regards.
Alix
34834

------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users
Reply | Threaded
Open this post in threaded view
|

Re: [#34834] docker remote (Docker Hub) : proxy not used for auth.docker.io

Alix Lourme

Hi Omar,

 

Thanks for answer. I will switch to support email for providing items (for verification), but I think I'm facing to RTFACT-8262 / RTFACT-8446.

 

Best Regards.

De : JFrog Support [mailto:[hidden email]]
Envoyé : jeudi 17 décembre 2015 04:48
À : ALIX LOURME - U171755
Cc : [hidden email]
Objet : Re: [#34834] docker remote (Docker Hub) : proxy not used for auth.docker.io

 

Hello Alix,

 

Thank you for contacting us. As an Artifactory Pro Enterprise customer, you can always contact JFrog Support directly at [hidden email], forums.jfrog.org is generally for Artifactory OSS users.

 

In order for us to better understand this issue, could you please provide us with the following information:

1. The full artifactory.log and request.log at $ARTIFACTORY_HOME/logs . Before sending the log files please add these loggers:

<logger name="org.artifactory.repo.HttpRepo">

<level value="debug"/>

</logger>

<logger name="org.artifactory.addon.docker">

<level value="debug"/>

</logger>

<logger name="org.artifactory.engine.DownloadService">

<level value="debug"/>

</logger>

 

These loggers should be added to $ARTIFACTORY_HOME/etc/logback.xml before reproducing this issue. Please note that there is no need to restart Artifactory after adding the loggers. Only to reproduce the issue.

 

2. The proxy server's configuration

3. The Artifactory and Docker client versions

 

Since this problem is fixed by setting a ‘System Default’ proxy in Artifactory, you may be experiencing this bug, however we would like to examine your logs to confirm.

 

Best Regards,

Omar

JFrog Support 

 Image supprimée par l'expéditeur.

On Wed, 16 Dec at 11:03 AM , Alix Lourme <[hidden email]> wrote:

Hi,

 

On Artifactory v4.3.2, a docker remote repository (on “Docker Hub”) seems not use the proxy configured in advanced tab.

 

Consider a simple docker configuration like doc : docker-local & docker-remote (behing company proxy) & docker-virtual (entry point).

 

This scenario works and validate the installation (internet proxy configured for docker deamon, for this sample … the objective is to use Artifactory as proxy)

$ docker pull busybox

$ docker tag busybox repository.company.com/test

$ docker push repository.company.com/test

$ docker images -aq | xargs docker rmi –f

$ docker pull repository.company.com/test

 

But trying using Artifactory as registry proxy for official images:

$ docker pull repository.company.com/ubuntu

 

Gives : “FATA[0001] Error: Status 400 trying to pull repository ubuntu: "{\n  \"errors\" : [ {\n    \"status\" : 400,\n    \"message\" : \"Unsupported docker v1 repository request for 'docker'\"\n  } ]\n}"”

 

In Artifactory log :

---

2015-12-16 14:42:28,001 [ajp-nio-8019-exec-4] [DEBUG] (o.a.u.PreemptiveAuthInterceptor:59) - Updating credentials for host https://registry-1.docker.io

2015-12-16 14:42:29,173 [ajp-nio-8019-exec-4] [ERROR] (o.a.a.d.r.DockerTokenProvider:183) - Error occurred while retrieving token from 'https://auth.docker.io/token?scope=repository:library/ubuntu:pull&service=registry.docker.io': auth.docker.io: unknown error

2015-12-16 14:42:29,182 [ajp-nio-8019-exec-4] [DEBUG] (o.a.a.d.r.DockerTokenProvider:184) - Error occurred while retrieving token from 'https://auth.docker.io/token?scope=repository:library/ubuntu:pull&service=registry.docker.io'.

java.net.UnknownHostException: auth.docker.io: unknown error

                at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method) ~[na:1.8.0_60]

---

 

=> The internet proxy configured for docker-remote (here: https://registry-1.docker.io/) seems not used for “sub call”, like https://auth.docker.io

 

Workaround: Configuring the proxy as “System Default” solve the problem, but has some impacts on company domain requests (“no hosts” can’t be configured on the proxy).

 

Best regards.

Alix

34834


------------------------------------------------------------------------------

_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users