pom is downloaded, but jar is not downloaded, why?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

pom is downloaded, but jar is not downloaded, why?

Guofeng Zhang

Hi,

 

Sometime the pom and pom.sha1 are downloaded successfully, but the corresponding jar file is not downloaded. I got a build error saying that I have to manually download the jar file. I check the remote repository settings but cannot figure it out.

 

What causes it?

 

Thanks

 

Guofeng

 

Reply | Threaded
Open this post in threaded view
|

Re: pom is downloaded, but jar is not downloaded, why?

Yoav Landman
Administrator
Anything in the log? It is possible that the jar download failed due to network timeout (the pom is much smaller). You should be able to see these kind of errors in the log.

Yoav

On Wed, Jan 14, 2009 at 10:43 AM, Guofeng Zhang <[hidden email]> wrote:

Hi,

 

Sometime the pom and pom.sha1 are downloaded successfully, but the corresponding jar file is not downloaded. I got a build error saying that I have to manually download the jar file. I check the remote repository settings but cannot figure it out.

 

What causes it?

 

Thanks

 

Guofeng

 


------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


Reply | Threaded
Open this post in threaded view
|

Re: pom is downloaded, but jar is not downloaded, why?

Frederic Simon
In reply to this post by Guofeng Zhang
Depending on the maven scope and which lifecycle you are executing, you may also end up with only the pom file.
For example: Declared runtime and execute compile.
If you have also another version of the same groupId/artifactId maven may load the pom but never chose to download the jar for this version.

On Wed, Jan 14, 2009 at 10:43 AM, Guofeng Zhang <[hidden email]> wrote:

Hi,

 

Sometime the pom and pom.sha1 are downloaded successfully, but the corresponding jar file is not downloaded. I got a build error saying that I have to manually download the jar file. I check the remote repository settings but cannot figure it out.

 

What causes it?

 

Thanks

 

Guofeng

 


------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users




--
http://www.jfrog.org/
http://freddy33.blogspot.com/
http://nothingisinfinite.blogspot.com/
Reply | Threaded
Open this post in threaded view
|

Re: pom is downloaded, but jar is not downloaded, why?

Guofeng Zhang
In reply to this post by Yoav Landman

There is no error log about it in artifactory.log, but  INFO lines saying retrieving jar/sh1/MD5 files twice.

 

I think the issue might be caused by the network connection. When the issue occurs, I browse repo1 with the browser and the repository responses the browser’s request very slowly.

 

When the issue occurs, sometime I need to remove the pom files in the Artifactory cache, then thing goes well. My question is, if Artifactory found the pom file in its cache but no jar file, will it retrieve the jar from the remote repository?

 

Thanks

 

Guofeng

 

From: Yoav Landman [mailto:[hidden email]]
Sent: Wednesday, January 14, 2009 6:11 PM
To: [hidden email]
Subject: Re: [Artifactory-users] pom is downloaded, but jar is not downloaded,why?

 

Anything in the log? It is possible that the jar download failed due to network timeout (the pom is much smaller). You should be able to see these kind of errors in the log.

Yoav

On Wed, Jan 14, 2009 at 10:43 AM, Guofeng Zhang <[hidden email]> wrote:

Hi,

 

Sometime the pom and pom.sha1 are downloaded successfully, but the corresponding jar file is not downloaded. I got a build error saying that I have to manually download the jar file. I check the remote repository settings but cannot figure it out.

 

What causes it?

 

Thanks

 

Guofeng

 


------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users

 

Reply | Threaded
Open this post in threaded view
|

Re: pom is downloaded, but jar is not downloaded, why?

Yoav Landman
Administrator
It will definitely retrieve the jar when asked for it by maven, but maven has to ask for it. If you do not see the request in the access.log, maven is not asking for it to be downloaded.

On Thu, Jan 15, 2009 at 4:40 AM, Guofeng Zhang <[hidden email]> wrote:

There is no error log about it in artifactory.log, but  INFO lines saying retrieving jar/sh1/MD5 files twice.

 

I think the issue might be caused by the network connection. When the issue occurs, I browse repo1 with the browser and the repository responses the browser's request very slowly.

 

When the issue occurs, sometime I need to remove the pom files in the Artifactory cache, then thing goes well. My question is, if Artifactory found the pom file in its cache but no jar file, will it retrieve the jar from the remote repository?

 

Thanks

 

Guofeng

 

From: Yoav Landman [mailto:[hidden email]]
Sent: Wednesday, January 14, 2009 6:11 PM
To: [hidden email]
Subject: Re: [Artifactory-users] pom is downloaded, but jar is not downloaded,why?

 

Anything in the log? It is possible that the jar download failed due to network timeout (the pom is much smaller). You should be able to see these kind of errors in the log.

Yoav

On Wed, Jan 14, 2009 at 10:43 AM, Guofeng Zhang <[hidden email]> wrote:

Hi,

 

Sometime the pom and pom.sha1 are downloaded successfully, but the corresponding jar file is not downloaded. I got a build error saying that I have to manually download the jar file. I check the remote repository settings but cannot figure it out.

 

What causes it?

 

Thanks

 

Guofeng

 


------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users

 


------------------------------------------------------------------------------
This SF.net email is sponsored by:
SourcForge Community
SourceForge wants to tell your story.
http://p.sf.net/sfu/sf-spreadtheword
_______________________________________________
Artifactory-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/artifactory-users


Reply | Threaded
Open this post in threaded view
|

Re: pom is downloaded, but jar is not downloaded, why?

aryudo
Was there a solution to this issue?

I'm getting this issue on an existing project all of a sudden. I'm using RAD 7.5 and m2eclipse 0.10.

Every jar and plugin requested is downloaded as a .pom and .sha1 file, and then the maven console complains that it cannot fine the artifact.

the .pom that are downloaded is the one that is deployed to our artifactory.
Reply | Threaded
Open this post in threaded view
|

Re: pom is downloaded, but jar is not downloaded, why?

scheruga
For me it was the dependency that was wrong.
I hat set the type to pom.
This happens by copying the xml snippet from artifactory.

I selected the pom file instead of the jar within artifactory which results in this wrong code snippet with the type set as "pom"